Download it now!
Bug 45136 - PC freezes with math document including grids created with Sinequanon in WMF image format
Summary: PC freezes with math document including grids created with Sinequanon in WMF ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2012-01-23 10:01 UTC by Maderios
Modified: 2019-11-21 06:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
math document causing the bug (449.50 KB, application/msword)
2012-01-23 10:01 UTC, Maderios
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maderios 2012-01-23 10:01:45 UTC
Created attachment 56048 [details]
math document causing the bug

Problem description:
Important: This bug concerns only the Linux version of LibreOffice. No problem with the Windows version.
I try to open and edit this math document including grids created with Sinequanon software
http://dl.free.fr/getfile.pl?file=/7xfy7rZr
It's very slow to open, the PC freezes, mainly when scrolling, the cpu is near 100%. It's impossible to edit this document.
When removing the grids, the bug disappears.
Sinequanon software is here:
http://patrice.rabiller.pagesperso-orange.fr/SineQuaNon/menusqn.htm
System:
Debian Squeeze and Wheezy
My hardware:
Core I7 Sandybridge 8Go Ram
Graphic card: 
Nvidia Quadro 600, 1Go memory
Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:

Expected behavior:

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0 Iceweasel/8.0
Comment 1 Maderios 2012-01-23 10:06:51 UTC
I described the bug there. It was reproduced by several people
https://linuxfr.org/forums/linuxg%C3%A9n%C3%A9ral/posts/probleme-libreoffice-avec-les-maths
Comment 2 tester8 2012-01-26 13:30:44 UTC
Reproduced with

LOdev 3.5.0rc1
e40af8c-10029e3-615e522-88673a2-727f724
Ubuntu 10.04.3 x86
Linux 2.6.32-37-generic Russian UI
Comment 3 Jean-Baptiste Faure 2012-12-16 08:06:42 UTC
I think the problem is the anti-aliasing for the graphics, mainly the grids which are strangely made.
To workaround: menu Tools > Options > LibreOffice > View > uncheck Use Anti-Aliasing (under Graphics Output).

Tested with Version 4.0.0.0.beta1+ (Build ID: 789ec89fceb949eee482ecb7731a3d7b1ac0660)

I do not have a MS-Windows version at hand to check if Anti-Aliasing for graphics output is enabled.

Best regards. JBF
Comment 4 QA Administrators 2015-01-05 17:52:30 UTC Comment hidden (obsolete)
Comment 5 Jean-Baptiste Faure 2015-01-07 05:49:45 UTC
Nothing really changed: scrolling is smoother if antialiasing is disabled for graphics as stated in comment #3.
Tested with LibreOffice 4.4.0.1.0+ built at home under Ubuntu 14.10.

Best regards. JBF
Comment 6 QA Administrators 2016-09-20 10:14:20 UTC Comment hidden (obsolete)
Comment 7 Jean-Baptiste Faure 2016-09-24 19:58:54 UTC
Nothing really changed.
If I am not wrong the grids are WMF images, that is a format which is not intended to be interoperable.

Best regards. JBF
Comment 8 Jean-Baptiste Faure 2016-09-24 20:11:56 UTC
I guess it is a duplicate of bug 45820.

Best regards. JBF
Comment 9 QA Administrators 2017-11-17 09:11:01 UTC Comment hidden (obsolete)
Comment 10 Jean-Baptiste Faure 2017-11-17 17:30:07 UTC
No problem anymore with LO 5.4 and current master. I tried with and without OpenGL enabled.

@Madeiros: please could you try again with your current LO version?

Best regards. JBF
Comment 11 QA Administrators 2018-11-18 03:42:14 UTC Comment hidden (obsolete)
Comment 12 Chris Sherlock 2019-11-21 06:33:03 UTC
This is no longer occurring, it is working in Libreoffice 6.3.2.

If you are still having issues, please let us know.