Bug Hunting Session
Bug 45249 - EDITING postgreSQL-SDBC No functions available in Query Designers
Summary: EDITING postgreSQL-SDBC No functions available in Query Designers
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.5.0 RC2
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Lionel Elie Mamane
URL:
Whiteboard: target:3.6.0 target:3.5.1
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-25 21:47 UTC by Drew Jensen
Modified: 2012-02-13 09:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot of query designer (85.17 KB, image/png)
2012-01-25 21:47 UTC, Drew Jensen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Drew Jensen 2012-01-25 21:47:38 UTC
Created attachment 56164 [details]
screen shot of query designer

Test system: Ubuntu 11.04 AMD64, Gnome, PostGres 8.4 (localhost), 9.1 (remote)

Open an ODB connecting to the psql server.
Create new query in designer view
Select a field
Select Functions - empty list.

The query parser is recognizing the functions; create a query in text view, but NOT using SQLdirect [tested simple stuff, sum, count, avg] and it runs correctly, if switched back to design view the funtions are displayed correctly in the desinger view and are not removed when saved - so it appears to be the drop down control w/empty list as the culprit here.

In the screen shot the test query was entered as:

SELECT COUNT( * ) FROM "public"."Master" AS "Master" WHERE "birthState" IN ( 'CA', 'NC' )

Then switched back to design view, you can see it picks up the count function. Added another column just to show what the function drop list displays.
Comment 1 Patrick Welche 2012-01-29 06:24:55 UTC
Just had a go and noticed: if I chose as Field, tablename.*, rather than tablename.fieldname, Count appears in the Function list. (I should be allowed to count(tablename.fieldname) too...)
Comment 2 Lionel Elie Mamane 2012-02-02 02:21:19 UTC
Reproduced in 3.4 and 3.5.

Seems to be PostgreSQL-SDBC specific.
Comment 3 franco.violi 2012-02-04 08:30:46 UTC
I do not know if this can help, but the same behaviour can be reproduced when using the jdbc connection on postgres.
Comment 4 Lionel Elie Mamane 2012-02-05 02:06:10 UTC
(In reply to comment #3)
> I do not know if this can help, but the same behaviour can be reproduced when
> using the jdbc connection on postgres.

Oh, thanks for that information.
Comment 5 Lionel Elie Mamane 2012-02-13 09:22:28 UTC
Fixed in master (3.6) and 3.5.1 with PostgreSQL-SDBC driver.

Not fixed with JDBC driver.