Bug 45301 - EDITING: Automatically highlight the text when a comment is inserted
Summary: EDITING: Automatically highlight the text when a comment is inserted
Status: RESOLVED DUPLICATE of bug 38244
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected)
3.4.5 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
Whiteboard: BSA
Depends on:
Reported: 2012-01-27 04:02 UTC by aburakd
Modified: 2012-01-27 06:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:

Please see the attached screen shot. (843.58 KB, image/png)
2012-01-27 04:02 UTC, aburakd

Note You need to log in before you can comment on or make changes to this bug.
Description aburakd 2012-01-27 04:02:39 UTC
Created attachment 56217 [details]
Please see the attached screen shot.

Problem description: 

When one highlights a word or a part of the text and Inserts a Comment, that word or part of the text doesn't get highlighted automatically as in every other word processor. And the lack of this convenience makes collaboration impossible not only with MS Word users, but also with potential LibreOffice users as well. Because of this inconvenience they could not be encouraged to use or switch to LibreOffice .

Suppose someone (using MS Word) sends you back your text with some inserted comments and (s)he says in the comments “Delete this” or “This is not true” etc., but all you see in LibreOffice is an arrow pointing the beginning or ending of a word. Now which part to “delete” or which part is “not true”? Just that last word or the last three ones or the whole sentence or the whole paragraph up to that word or…?

This problem persists in every Linux distro as well as in Mac OS X. Don't know about Windows. 

Steps to reproduce:

1. Highlight some text
2. Insert / Comment

Current behavior:

The commented text doesn't get highlighted automatically

Expected behavior:

The commented text should be highlighted automatically

Platform (if different from the browser): 
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:10.0) Gecko/20100101 Firefox/10.0
Comment 1 GerardF 2012-01-27 06:59:08 UTC
Duplicate of 38244.

*** This bug has been marked as a duplicate of bug 38244 ***