Download it now!
Bug 45318 - : Password Protected Document or Spreadsheet cannot be opened
Summary: : Password Protected Document or Spreadsheet cannot be opened
Status: RESOLVED DUPLICATE of bug 45171
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-27 09:03 UTC by timjohn7
Modified: 2012-01-27 09:50 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description timjohn7 2012-01-27 09:03:57 UTC
Problem description: I saved a Calc Spreadsheet with Password protection using LibreOffice Version 3.4.4
I then updated to Version 3.4.5 using Ubuntu Update manager.
The spreadsheet cannot be opened using the correct, verified password.
The same problem exists for text document saved with password protection under a previous version.
Both files opened normally using the same passwords using an old version of OpenOffice (3.2)

Steps to reproduce:
1. Using LibreOffice 3.4.4, create new spreadsheet.
2. File -> Save As -> AnyName.ods -> Check Save with password -> Save -> Enter password -> Repeat password -> Save
3. Update LibreOffice to Version 3.4.5
4. File -> Open AnyName.ods
5. Enter password

Current behavior:
Spreadsheet cannot be opened.  Error Message "The password is incorrect. The file cannot be opened."

Expected behavior:
Spreadsheet opens and can be edited normally.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.77 Safari/535.7
Comment 1 meilan 2012-01-27 09:32:54 UTC
Confirm this, Libreoffice 3.4.5 (Calc and Writer) have problems when create or open documents with passwords.
Comment 2 timjohn7 2012-01-27 09:43:11 UTC
The problem appears even more serious.
I tried saving both a Calc spreqadsheet and a Writer document with password protection and they both fail to save (using Version 3.4.5).
Both give the same error message: "Error saving the document Untitled2. General error.  General input/output error."
Comment 3 meilan 2012-01-27 09:50:40 UTC

*** This bug has been marked as a duplicate of bug 45171 ***