Bug Hunting Session
Bug 45340 - LO 3.4.5 Calc fails to print an .xls file correctly
Summary: LO 3.4.5 Calc fails to print an .xls file correctly
Status: RESOLVED DUPLICATE of bug 44664
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-01-28 09:49 UTC by mab
Modified: 2012-05-04 03:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mab 2012-01-28 09:49:42 UTC
(Using a fully-updated Mandriva 2010.2 32-bit PowerPack.)

When LO 3.4.5 is asked to handle the file:
  
    http://dl.dropbox.com/u/10969499/scorecard.xls

- although its Print Preview shows the output correctly (in Landscape orientation), it appears to send the output image in Portrait orientation, causing the printing to terminate prematurely soon after the "H.C. Points" column has been printed.
  Thus the printed page is missing all output to the right of that column (after the beginning of the "Exp" column).

Reports indicate the same problem under Mandriva 2010,2 and Mageia 1, but with a different problem (left-hand column missing) under Ubuntu 11.1.

N.B. The same file prints perfectly under OpenOffice on those systems.

Also, users of Windows 7 and iMac installations report no problem with LO here.
Comment 1 mab 2012-02-02 10:11:04 UTC
> The same file prints perfectly under OpenOffice on those systems.

The difference between OpenOffice and LO w.r.t. to the landscape file is that OpenOffice outputs the file as Postcript, whereas LO uses PDF.

If the LO print setting for the file is changed from PDF to Postscript, then it prints perfectly, so it seems LO should use Postscript in this situation.
Comment 2 Cor Nouws 2012-02-03 10:12:52 UTC
Hi,
thanks for the report.

(In reply to comment #0)
> N.B. The same file prints perfectly under OpenOffice on those systems.

Do you know which version? As from OOo 3.3.0 and DEV300m105 (the untimely ended line towards 3.4.0). 
I have and see a pile of issues with page handling and printing. And the most slipped in LibreOffice :-\
I tried to help with QA in the OOo time with some issues and comments in that time, but aparently there were not enough people working on it.

I think it would be good if we set up a special group/taks force to work together in ditching out all the issues and make a clear overview for the devs to step in..

By the way: I'm on the train and cannot check the issue (forgot to carry my printer ;-) ) but simple expect that indeed it is a bug.
Comment 3 Cor Nouws 2012-02-03 10:16:21 UTC
I now see your additional info on the users list. Thanks.
Pasting it here for reference:
" A workaround has been found by 'TJ' in the Mandriva newsgroup:

   When in LO's 'print file', go in to Printer Settings and change
'PDF' to 'Postscript' (any level).

(Unfortunately the change does not stick, unless the document is
changed and Saved.)

The reason why OpenOffice is able to print the file perfectly is that
it already uses Postscript in the output.
  For background to that, see:

  https://issues.apache.org/ooo/show_bug.cgi?id=94173
   
where the proposed change from Postscript to PDF (to solve *other*
problems) did not make it into OpenOffice before it ws handed over to
Apache, whereas they *did* make it into LO! "
Comment 4 mab 2012-02-03 11:25:58 UTC
>  Do you know which version?

  OpenOffice 3.2.1

I have just tried the same file on PCLinuxOS 2011.6, which has LO 3.4.5 and CUPS 1.4.6.

The result was the same as for OpenSUSE 12.1:

   The file displays correctly for Print Review (in landscape) but prints as Portrait, right to the right-hand edge of the physical page, thus truncating the layout at the same column where LO 3.4.5 on Mandriva stopped printing columns (in landscape)....

As before, if the LO Print Settings for the file are changed from "PDF" to "Postscript (from the driver)", the file prints perfectly, in landscape.
Comment 5 mab 2012-02-03 13:38:38 UTC
Have now tried the .xls file with Mandriva 2011's LO 3.4.3 (CUPS 1.4.8):

LO's print Review correctly showed in Landscape, but then sent a Portrait print file which printed in Landscape, so that all columns to the right of "H.C. Points" were missing details. (Same result as Mandriva 2010.2).
   The LO printer Settings showed PDF. When that was changed to 'Postscript', the file printed perfectly...
Comment 6 Cor Nouws 2012-04-15 14:04:17 UTC
Hi mab,
Working on some issues today, I noticed that this issue is already filed before.
Pls look there for more info!

*** This bug has been marked as a duplicate of bug 44664 ***
Comment 7 Roman Eisele 2012-05-04 03:21:21 UTC
This is a Calc issue, therefore changed the 'Component' field appropriately.