Download it now!
Bug 45417 - FORMATTING: Loss of formatting in auto fields (e.g. Page Number), .doc files
Summary: FORMATTING: Loss of formatting in auto fields (e.g. Page Number), .doc files
Status: RESOLVED DUPLICATE of bug 38778
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-30 15:54 UTC by richard.strangelove
Modified: 2013-06-22 09:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
document where number of page uses font Curier (8.69 KB, application/vnd.oasis.opendocument.text)
2012-05-14 06:27 UTC, sasha.libreoffice
Details
the same document, saved as doc using msWord 2007 (correctly) (26.50 KB, application/msword)
2012-05-14 06:28 UTC, sasha.libreoffice
Details
saved using Writer 3.5.3 (font lost) (9.00 KB, application/msword)
2012-05-14 06:29 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description richard.strangelove 2012-01-30 15:54:26 UTC
Problem description: 

Files saved as .doc lose font associated with fields.

Steps to reproduce:
1. Create a new document
2. Insert > Field > Page Number
3. Select the text in the Page Number field
4. Choose a different font for it (e.g. Courier New -- something that's not the default)
5. File > Save as > Microsoft Word 97/2000/XP/2003 (.doc)
6. Close document
7. Reopen it in Libreoffice

Current behavior:
Contents of field will have reformatted into a different style.

Expected behavior:
Field will remain the same, maintaining the original formatting.

Note: This is only the case with .doc; it works as expected in the native .odf file format.  It only seems to change the font -- other formatting seems to stay intact.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux i686; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Comment 1 sasha.libreoffice 2012-05-14 06:27:45 UTC
Created attachment 61614 [details]
document where number of page uses font Curier
Comment 2 sasha.libreoffice 2012-05-14 06:28:43 UTC
Created attachment 61615 [details]
the same document, saved as doc using msWord 2007 (correctly)
Comment 3 sasha.libreoffice 2012-05-14 06:29:29 UTC
Created attachment 61616 [details]
saved using Writer 3.5.3 (font lost)
Comment 4 sasha.libreoffice 2012-05-14 06:33:07 UTC
Thanks for bugreport
reproduced in 3.3.4 and 3.5.3 on Fedora 64 bit and Windows 7 32 bit
Changing version to 3.3.4 as most early reproducible

Workaround: use odt format for transferring documents to msWord
Comment 5 ign_christian 2013-06-22 09:42:03 UTC

*** This bug has been marked as a duplicate of bug 38778 ***