Download it now!
Bug 45481 - EDITING: undo incomplete for pasted column from text editor
Summary: EDITING: undo incomplete for pasted column from text editor
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:3.5.1 target:3.6
Keywords: regression
: 46189 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-01 00:14 UTC by Rainer Bielefeld Retired
Modified: 2012-02-16 14:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Source Document (8.70 KB, application/3dr)
2012-02-01 00:14 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-02-01 00:14:40 UTC
Created attachment 56426 [details]
Source Document

Steps to reproduce with "LibreOffice 3.5.0 RC2 German UI/Locale [Build-ID: e371a95-bf68a13-5a1aa2b-d3c1ae9-b938258] on German WIN7 Home Premium (64bit):
1. open attached “textsample.odt” (you can easily create own sources)
2. <control+a> to select all
3. <conrol+c> for copy
4. Menu 'File → New → Spreadsheet'
5. Click A1 if necessary
6. <conrol+v> for paste
   > Column with contents 1 … 0 appears
7. Click Undo-Button in toolbar
   Expected: all pasted contents will disappear 
   Actual: Character formatting changes

Might be interesting: In spreadsheet I do not see any Font name selected before step 7

I see the same problem with a pasted column from editor EditPad

Works fine "LibreOffice 3.4.5 German UI [Build ID: OOO340m1 (Build:502)]" parallel Server installation on German WIN7 Home Premium (64bit), so REGRESSION
Comment 1 Rainer Bielefeld Retired 2012-02-01 00:26:49 UTC
Last version where it worked for me: 
Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID:  d3d1481-3f8994a-2ba0a9f)]" (2011-09-09)

First version showing problem for me:
Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID: 81607ad-3dca5fd-da627d2)]" Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID: 81607ad-3dca5fd-da627d2)]" (2011-09-13)
Comment 2 Rainer Bielefeld Retired 2012-02-01 00:31:09 UTC
It's not related to user profile
Comment 3 Markus Mohrhard 2012-02-08 11:00:07 UTC
Will look into it.
Comment 4 Markus Mohrhard 2012-02-08 14:41:42 UTC
fixed in master, will ask for review for 3-5
Comment 5 Markus Mohrhard 2012-02-16 14:04:19 UTC
*** Bug 46189 has been marked as a duplicate of this bug. ***