Bug 45548 - VIEWING, UI: New Indicators for Header/Footer display and are usable in read-only Documents
Summary: VIEWING, UI: New Indicators for Header/Footer display and are usable in read-...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 Beta2
Hardware: All All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
: 44183 45699 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-02 07:30 UTC by famo
Modified: 2012-02-29 06:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Page Break Indicator in Help View (31.76 KB, image/png)
2012-02-02 07:33 UTC, famo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description famo 2012-02-02 07:30:24 UTC
The new page break indicators show up in read-only documents (like the help pages) and are even usable. So one can add/remove header and even change the page format, background etc.
However none of theses changes are really saved, so after closing and reopening everything is reverted to initial state.

So a minor issue, but still annoying/disturbing, especially on the help pages.
Comment 1 famo 2012-02-02 07:32:18 UTC
@Cédric:
Please have a look.
Comment 2 famo 2012-02-02 07:33:13 UTC
Created attachment 56521 [details]
Page Break Indicator in Help View
Comment 3 Cédric Bosdonnat 2012-02-13 02:22:05 UTC
Fixed in branch master (3.6) by this commit:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=beb8a85796c78d4cdcf6497b6725fce8f7141d75
Comment 4 famo 2012-02-15 13:15:22 UTC
Thanks, and what about the 3.5 series, ie. for 3.5.1 ?
Comment 5 famo 2012-02-15 13:17:47 UTC
*** Bug 44183 has been marked as a duplicate of this bug. ***
Comment 6 Cédric Bosdonnat 2012-02-16 00:29:16 UTC
(In reply to comment #4)
> Thanks, and what about the 3.5 series, ie. for 3.5.1 ?

Reviewed and pushed to 3-5 branch as well:
http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-5&id=de03d27c597b1f56d5d68d1a8181e2889dc5b1cb
Comment 7 Andras Timar 2012-02-29 06:55:00 UTC
*** Bug 45699 has been marked as a duplicate of this bug. ***