Bug 45550 - FILESAVE: turning of text / objects not retained when saving as ppt or pptx
Summary: FILESAVE: turning of text / objects not retained when saving as ppt or pptx
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-02 08:06 UTC by Oliver
Modified: 2017-10-19 15:37 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
original file in odp format : text and form turned by 90° (12.70 KB, application/vnd.oasis.opendocument.presentation)
2012-02-02 08:06 UTC, Oliver
Details
ppt saved file with turned text retained, but not turned shape/text (70.50 KB, application/vnd.ms-powerpoint)
2012-02-02 08:07 UTC, Oliver
Details
pptx saved file with turned text and shape not retained (17.92 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2012-02-02 08:07 UTC, Oliver
Details
ODP presentation with text rotated 0, 90, 180, 270, and 45 degrees (11.95 KB, application/vnd.oasis.opendocument.presentation)
2014-04-30 12:01 UTC, cousteau
Details
Previous ODP with turned text, saved as PPT (75.00 KB, application/vnd.ms-powerpoint)
2014-04-30 12:05 UTC, cousteau
Details
priginal odp file with different turned text and shapes with text (14.12 KB, application/vnd.oasis.opendocument.presentation)
2016-11-09 08:00 UTC, Oliver
Details
ppt version saved with LO 5.2.3.3 of 128601 (160.00 KB, application/x-ole-storage)
2016-11-09 08:01 UTC, Oliver
Details
pptx version saved with LO 5.2.3.3 of 128601 (35.43 KB, application/zip)
2016-11-09 08:02 UTC, Oliver
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver 2012-02-02 08:06:15 UTC
Created attachment 56533 [details]
original file in odp format : text and form turned by 90°

Problem description: 
saving turned text in ppt or pptx will result in formating problems

Steps to reproduce:
1. create a) simple text and then turn it 90 degrees countre clockwise ; b) create a shape (e.g. arrow shape pointing right), insert text by doubleclicking on it, then turn the shape 90 degrees counter clockwise
2. save as odp, ppt or pptx

Current behavior:
3. open odp : everything stay turned OK; open ppt : simple text is OK, but arrow has turned 90 degrees clockwise (so is in original direction, but not the same shape), however text has turned by 180degrees, thus now reads from top to bottom instead of bottom to top; open pptx : both texts and shape are again horizontal, and additionally have changes place

Expected behavior:
turned text or objects should stay turned


Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20120129 Firefox/10.0 SeaMonkey/2.7
Comment 1 Oliver 2012-02-02 08:07:12 UTC
Created attachment 56534 [details]
ppt saved file with turned text retained, but not turned shape/text
Comment 2 Oliver 2012-02-02 08:07:45 UTC
Created attachment 56535 [details]
pptx saved file with turned text and shape not retained
Comment 3 sasha.libreoffice 2012-05-14 07:51:17 UTC
Thanks for bugreport
Problem with saving to ppt:
reproduced in 3.3.4 and 3.5.3 on Fedora 64 bit, FILESAVE problem
Problem with saving to pptx: not tested

Also: attached odp not conforms to odf format.
PS: msPP 2007 opens attached odp file incorrectly, both objects rotated in wrong direction.

changing version to 3.3.4 as most early reproducible
Comment 4 A (Andy) 2013-04-25 20:50:45 UTC
buggy behavior partly reproducible with LO 4.0.2.2 (Win7 Home, 64bit)

Result:
ppt file seemed to be ok: no wrong rotation, is like in the odp file

but the pptx file is buggy: no wrong rotation, but the arrow is changed
Comment 5 cousteau 2014-04-30 12:01:40 UTC
Created attachment 98235 [details]
ODP presentation with text rotated 0, 90, 180, 270, and 45 degrees
Comment 6 cousteau 2014-04-30 12:05:39 UTC
Created attachment 98236 [details]
Previous ODP with turned text, saved as PPT

This is the previous ODP containing turned text I attached, converted to PPT with LibreOffice 4.1.1.2.

Result:
* When open with LibreOffice, both Left and Right appear upside down.
* When open with MS Office, only Right appears upside down, and Left appears correctly.

Both the diagonal and upside down text appear correctly.  This is not an issue with PPTX files.
Comment 7 Stephan van den Akker 2014-04-30 17:17:14 UTC
Using LOdev Version: 4.3.0.0.alpha1+
Build ID: 81272fdb1e093d44e2e67eba65c79a490832f320
On openSuSE 13.1 (64-bit)

Saving attachment 98235 [details] as ppt: Same results as comment 6.
Saving attachment 98235 [details] as pptx: Text "Reversed" is shifted to the right page margin (opened in LOdev 4.3 and MSO 2007).
Comment 8 QA Administrators 2015-06-08 14:42:45 UTC Comment hidden (obsolete)
Comment 9 Buovjaga 2015-08-02 10:35:07 UTC
(In reply to A (Andy) from comment #4)
> buggy behavior partly reproducible with LO 4.0.2.2 (Win7 Home, 64bit)
> 
> Result:
> ppt file seemed to be ok: no wrong rotation, is like in the odp file
> 
> but the pptx file is buggy: no wrong rotation, but the arrow is changed

Confirmed.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 902255645328efde34ddf62227c8278e8dd61ff0
TinderBox: Win-x86@39, Branch:master, Time: 2015-07-30_03:52:07
Locale: en-US (fi_FI)
Comment 10 QA Administrators 2016-11-08 11:54:21 UTC Comment hidden (obsolete)
Comment 11 Oliver 2016-11-09 07:58:55 UTC
The problem is still there : 
I have followed the original instructions, but additionally I have also turned texte and shape by 45 degrees and also by 180 degrees (that is upside down. The results are as following : 

 * saving adn reopening wiht odp : all stays the same
 * saving as ppt and reopening with Libreoffice : the text turned 90° is now upside down, the shape with text turned 90° is correct; Text and shape turned 45° are correct; text and shape upside down are correct
  * saving as pptx and reopening in Libreoffice : 90° and 45° turned text and shape with text are OK, text and shape with text upside down are still upside down, but not at the correct position but shifted to the right

So for some reason it depends on how much a text / shape with text is turned to get a change when saving as ppt or pptx. 
I have attached the example files
Comment 12 Oliver 2016-11-09 08:00:20 UTC
Created attachment 128601 [details]
priginal odp file with different turned text and shapes with text
Comment 13 Oliver 2016-11-09 08:01:58 UTC
Created attachment 128602 [details]
ppt version saved with LO 5.2.3.3 of 128601
Comment 14 Oliver 2016-11-09 08:02:37 UTC
Created attachment 128603 [details]
pptx version saved with LO 5.2.3.3 of 128601
Comment 15 Oliver 2016-11-09 08:03:28 UTC
Sorry forgot to mention, I used LO 5.2.3.3 for these new tests of this bug
Cheers
Comment 16 Xisco Faulí 2017-10-19 15:37:06 UTC
Fixed in

Version: 6.0.0.0.alpha0+
Build ID: cfbb8b5090537e79ba70e250ddee86d53facbe15
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

[Improvement found by office-interoperability-tools]