Download it now!
Bug 45563 - incorrect IMPORT of Zotero RTF, regression
Summary: incorrect IMPORT of Zotero RTF, regression
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: highest major
Assignee: Christina Rossmanith
URL:
Whiteboard: target:3.5.2
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-02 12:52 UTC by Hassan Chamati
Modified: 2012-03-21 22:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
ODT demonstrating what the bibliography should look like (10.07 KB, application/vnd.oasis.opendocument.text)
2012-03-12 01:17 UTC, Christina Rossmanith
Details
RTF which is imported wrong due to DOS line ends. (1.11 KB, application/rtf)
2012-03-12 01:18 UTC, Christina Rossmanith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hassan Chamati 2012-02-02 12:52:31 UTC
RTF files produced by Zotero are not displayed correctly in LO 3.5.0rc3 under ubuntu 11.10 x64. The same file opens normally in LO 3.4.5.
Comment 1 Hassan Chamati 2012-02-18 10:39:28 UTC
Still not resolved in LO 3.5. This seems to be a serious problem of LO 3.5. Ti cannot handle rtf file correctly.
Comment 2 Christina Rossmanith 2012-03-12 01:17:29 UTC
Created attachment 58302 [details]
ODT demonstrating what the bibliography should look like
Comment 3 Christina Rossmanith 2012-03-12 01:18:47 UTC
Created attachment 58303 [details]
RTF which is imported wrong due to DOS line ends.
Comment 4 Not Assigned 2012-03-13 02:12:00 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9f5dfe07794130a96b7c2056f468354cb8d750ff

Related: fdo#45563 RTF import of \r should be the same as \par
Comment 5 Not Assigned 2012-03-13 02:24:01 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e5823e8513eee31fd96549a4b0273063ed31b192

testcase for fdo#45563
Comment 6 Miklos Vajna 2012-03-13 02:43:57 UTC
Set target and close - thanks Christina!
Comment 7 Jean-Baptiste Faure 2012-03-21 22:30:30 UTC
Hi Miklos,
Works well now in master.
Any reason why this fix is not backported to LO 3.5 branch ?

Best regards. JBF