Bug 45583 - Character encoding mess: Cyrillics from Writer to Calc
Summary: Character encoding mess: Cyrillics from Writer to Calc
Status: RESOLVED DUPLICATE of bug 36144
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-03 03:35 UTC by Yugov Ivan
Modified: 2012-02-29 06:49 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yugov Ivan 2012-02-03 03:35:21 UTC
Windows XP SP3 Home, Russian version
Default codepage is Windows-1251.

Steps to reproduce:
1. Open Writer.
2. Type any cyrillic text with DEFAULT font.
3. Copy text into the clipboard.
3. Open Calc.
4. Double-click in any cell or in formula field.
5. Paste text from clipboard.

Cyrillic encoding becomes Central-European or so: vowels with accents etc.

If you select font in Writer explicitly (even the same), then it's OK.
If you paste to Calc as unformatted text, then it's OK, too.

However, it should be possible to paste formatted text with proper character encoding.
Comment 1 sasha.libreoffice 2012-02-22 02:11:15 UTC
reproduced in 3.5.0 beta 3 on Windows XP 32 bit Russian locale
Comment 2 sasha.libreoffice 2012-02-29 06:49:10 UTC

*** This bug has been marked as a duplicate of bug 36144 ***