Download it now!
Bug 36144 - Text copied from Writer pasted with wrong encoding on Windows
Summary: Text copied from Writer pasted with wrong encoding on Windows
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 36550 38323 43088 45583 52072 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-11 20:12 UTC by Alexey
Modified: 2013-11-24 19:28 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
(Ctrl+C from LO 3.3.2 Writer)->(Ctrl+V in LO 3.3.2 Impress) (211.60 KB, application/x-7z-compressed)
2011-04-11 20:12 UTC, Alexey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey 2011-04-11 20:12:26 UTC
Created attachment 45496 [details]
(Ctrl+C from LO 3.3.2 Writer)->(Ctrl+V in LO 3.3.2 Impress)

Hi! My name is Alex. I'm from Russia. I moved to LibreOffice. Encountered the following problem: copy the Russian text (Ctrl+C) from LibreOffice Writer and paste (Ctrl+V) in LibreOffice Impress problems with encoding. With English text is all right. The problem appeared to OS Windows XP (RUS) SP3.

Tried on Ubuntu. Everything works fine.

The fact that I have found a partial solution to the
problem. By default,LO Writer font is Times New Roman. In LO Impress default
is Arial.
If you copy from LO Writer, install it the font Arial, the problem arises from
time to timewith the coding!
Do you have ideas to fix this??
Problem version "LibrOffice 3.3.2 OOO330m19 (Build: 202) tag
libreoffice-3.3.2.2"

In version "LibrOffice 3.3.1 OOO330m19 (Build: 8) tag
libreoffice-3.3.1.2" appeared the same problem!

Help solve the problem!!
Comment 1 Alexey 2011-04-12 01:53:28 UTC
Analogicheaya problem arises in "Windows 7 Ultimate (version 6.1 build 7601: Service Pack 1)"
Comment 2 sasha.libreoffice 2011-12-21 07:14:16 UTC
Please, see my comment in Bug 39890 My be it can somehow help with this problem
Comment 3 Björn Michaelsen 2011-12-23 12:05:46 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 4 sasha.libreoffice 2012-02-27 06:28:48 UTC
Reproduced in 3.5.0 beta 3 on Windows XP 32bit
To reproduce problem copy non-latin text in Writer and place cursor into existing frame in Imprass, then paste.
Problem appears only when copy from Writer.
IMHO problem exist not only with Cyrillic text. But to reproduce problem we should use the same language that Windows locale is. For example, if Windows locale is Chinese, then we should use Chinese to reproduce this problem.
IMHO Writer not provides information about language in Clipboard. (Writer uses DOS (OEM) encoding for place text into Clipboard.)
Comment 5 sasha.libreoffice 2012-02-27 06:34:35 UTC
With pasting into Calc and Draw also problem
In Calc in formula line text appears correct, but in cell text is wrong
In Draw when just paste text, appears frame with correct text, but if place cursor there and paste text, text encoding is wrong.
Comment 6 sasha.libreoffice 2012-02-27 06:35:48 UTC
@ Tor
Please, look at this bug. Windows specific problem with encoding.
Comment 7 sasha.libreoffice 2012-02-29 06:47:51 UTC
*** Bug 38323 has been marked as a duplicate of this bug. ***
Comment 8 sasha.libreoffice 2012-02-29 06:49:10 UTC
*** Bug 45583 has been marked as a duplicate of this bug. ***
Comment 9 sasha.libreoffice 2012-02-29 06:50:28 UTC
*** Bug 43088 has been marked as a duplicate of this bug. ***
Comment 10 Roman Eisele 2012-05-03 10:20:55 UTC
Summary modified according to comment #5 (not only Writer is affected!) and comment #6 (a Windows-specific problem). Also tried to improve style.

If the summary is now too short/unspecific, please improve it if you can ;-)
Comment 11 Roman Eisele 2012-05-03 10:23:54 UTC
Oh, sorry, I can improve the summary myself once more! I must have overseen comment #4: problem occurs only when pasting text copied from Writer.
Comment 12 Urmas 2012-07-14 07:48:03 UTC
*** Bug 52072 has been marked as a duplicate of this bug. ***
Comment 13 sasha.libreoffice 2012-08-31 10:16:19 UTC
*** Bug 36550 has been marked as a duplicate of this bug. ***
Comment 14 Urmas 2012-11-23 17:51:15 UTC
It works in 4.0-master. So tentatively Fixed.
Comment 15 sasha.libreoffice 2012-11-24 07:21:28 UTC
Status "Fixed" used only when we know exact patch which fixes this bug
Changing to WFM