Download it now!
Bug 45633 - Viewing: Will not view (open) LWP (Lotus WordPro) files as advertized
Summary: Viewing: Will not view (open) LWP (Lotus WordPro) files as advertized
Status: RESOLVED DUPLICATE of bug 41702
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-04 17:43 UTC by Greg
Modified: 2014-07-26 10:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
LWP file that won't open (35.62 KB, application/vnd.lotus-wordpro)
2012-02-04 17:43 UTC, Greg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Greg 2012-02-04 17:43:03 UTC
Created attachment 56613 [details]
LWP file that won't open

LibreOffice was advertized as having the ability to open Lotus WordPro (LWP) files.  The LWP file that the LibreOffice web site as its sample opens fine.  However, none of my clients LWP files open.  There is just a blank screen, like creating a new document when trying to open the LWP.  Attached (as suggested) is an LWP file that will not open.
Comment 1 sasha.libreoffice 2012-05-15 03:11:42 UTC
Thanks for bugreport
Currently in 3.5.3 not opens, therefore change status to New
AFAIK opening lwp is among tasks for GSoC 2012, but nobody taken it
Comment 2 Owen Genat (retired) 2014-07-26 10:11:27 UTC
For reference, here is a comparison of the headers of the attachment in bug 41702 (Unteress_test.lwp) and the attachment for this bug (CALVARY.LWP):

$ hexdump -n50 -C Unteress_test.lwp 
00000000  57 6f 72 64 50 72 6f 0d  fb 00 00 00 00 00 00 00  |WordPro.........|
00000010  00 05 98 5c 81 72 03 00  40 cc c1 bf ff bd f9 50  |...\.r..@......P|
00000020  99 89 03 0a 00 bc 1a d8  4e 02 00 7a dc b4 d1 11  |........N..z....|
00000030  00 00                                             |..|
00000032
$ hexdump -n50 -C CALVARY.LWP 
00000000  57 6f 72 64 50 72 6f 0d  fb 00 00 00 00 00 00 00  |WordPro.........|
00000010  00 05 98 5c 81 72 03 00  40 cc c1 bf ff bd f9 50  |...\.r..@......P|
00000020  99 89 03 09 00 08 12 98  0b 79 08 08 c0 08 00 00  |.........y......|
00000030  03 00                                             |..|
00000032

Here is a dump of the header for a WordPro file that does open:

$ hexdump -n50 -C finanzen\ 2013.lwp 
00000000  57 6f 72 64 50 72 6f 00  00 00 00 00 00 00 00 00  |WordPro.........|
00000010  4c 57 50 37 00 00 00 00  00 00 00 00 00 00 00 00  |LWP7............|
00000020  00 00 ff ff ff ff 00 00  00 00 2e 00 00 00 01 07  |................|
00000030  0f 00                                             |..|
00000032

There is a note in the source code indicating that Word Pro 96 and previous versions are unsupported, which may be related to why the attachment to this bug does not open.

*** This bug has been marked as a duplicate of bug 41702 ***