Bug 45667 - FILEOPEN particular .DOCX (MSO2007): watermark background picture shown as multiple foreground pictures
Summary: FILEOPEN particular .DOCX (MSO2007): watermark background picture shown as mu...
Status: RESOLVED DUPLICATE of bug 35324
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-05 22:14 UTC by Brian Lipscomb
Modified: 2013-06-15 12:47 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Attached is a Word 2010 sample document with an image watermark. (191.52 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-02-05 22:14 UTC, Brian Lipscomb
Details
PDF of what the document should look like if watermark is properly rendered (131.82 KB, application/pdf)
2012-02-05 22:16 UTC, Brian Lipscomb
Details
DOCX MS 2007 with a watermark (18.40 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-03-05 04:09 UTC, Daniel Espinosa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Lipscomb 2012-02-05 22:14:10 UTC
Created attachment 56640 [details]
Attached is a Word 2010 sample document with an image watermark.

Problem description: A document created in MS Word 2007 or 2010 with an image watermark opens incorrectly in LibreOffice Writer. The image will no longer be shown as a watermark but will appear at the top of the document, pushing the text down below it.

Steps to reproduce:
1. Create a simple text document in Word 2007 or 2010
2. Ad an image watermark, save document
3. Open in LibreOffice Writer

Current behavior: Watermarked image appears as first item of the document and color is no longer "faded" as it was in Word. The document text is pushed down below the image.

Expected behavior: Watermarked image should remain layered underneath the text and be shaded accordingly.

Platform (if different from the browser):
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0
Comment 1 Brian Lipscomb 2012-02-05 22:16:37 UTC
Created attachment 56641 [details]
PDF of what the document should look like if watermark is properly rendered
Comment 2 Jasper Knockaert 2012-03-18 14:18:03 UTC
I can confirm that the bug is still there in LibreOffice 3.5.1 release. I guess the bug is with the new docx importer (LibreOffice 3.5.0 was the first version where I noticed this behaviour).
Comment 3 sasha.libreoffice 2012-03-19 08:15:41 UTC
Reproduced in 3.3.4, 3.5.1 on Fedora and in 3.4.3 on Windows 7
All as described, except that in 3.5.1 instead of 1 image we see 3.
Changing version to 3.3.4 as most early reproducible
Comment 4 Rainer Bielefeld Retired 2012-12-26 16:20:00 UTC
[Reproducible] with server installation of "LibreOffice 3.5.7.2 rc German UI/Locale [Build-ID: 3215f89-f603614-ab984f2-7348103-1225a5b] on German WIN7 Home Premium (64bit) 

With 3.6 the appearance of the problem has changed, "LibreOffice 3.6.4.3" German UI/ German Locale [Build-ID: 2ef5aff] {pull date 2012-11-28} on German WIN7 Home Premium (64bit) shows 2 pictures one upon the other and a third one hidden.

@Michael:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf
Comment 5 Rainer Bielefeld Retired 2012-12-26 16:40:24 UTC
At least parts of the problems here might be related to or DUP of "Bug 35324 - FILEOPEN particular .docx: Watermark background picture shown in foreground"
Comment 6 Goran Rakic 2013-01-25 18:58:40 UTC
I am very sure this is a duplicate of #35324
Comment 7 Rainer Bielefeld Retired 2013-01-25 22:22:05 UTC
@grakic@devbase.net
<http://wiki.documentfoundation.org/BugReport_Details#Version>
If you also did this mistake in other Bugs please undo your Version changes there!

You DUP suspect sounds very plausible, let's check that tomorrow!
Comment 8 Daniel Espinosa 2013-03-05 04:09:23 UTC
Created attachment 75936 [details]
DOCX MS 2007 with a watermark

If this help I have created a MS 2007 docx with file a watermark, if LO Writer open it, shows the image but is not a watermark any more but an image that push th text around it.
Comment 9 Thomas van der Meulen 2013-06-15 12:47:25 UTC

*** This bug has been marked as a duplicate of bug 35324 ***