Download it now!
Bug 45669 - Base on MacOS X: Pasting through menu or keyboard shortcut doesn't not work
Summary: Base on MacOS X: Pasting through menu or keyboard shortcut doesn't not work
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 50479 52295 89503 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-06 00:29 UTC by Justin Clift
Modified: 2017-10-12 16:46 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Clift 2012-02-06 00:29:58 UTC
Hi,

Created a simple database using the built in LO database, then tied a simple form to it, consisting of "Formatted Field" and "Text Box" fields.

*Pasting* of text from applications (ie Apple Mail, LibreOffice Spreadsheet, Apple TextEdit) into any of the text field types does not work.

This is with very simple text, such as "Hi, my name is Fred."  (simple example)

Tried the following methods for pasting:

 a. Using keyboard shortcut ⌘-v : Does not work
 b. <Main menu> -> Edit -> Paste : Does not work
 c. Right click context menu -> Paste : _Works_ fine

When I say "Does not work", I mean that no apparent action occurs at all.  It's like the action is completely ignored by LO.  The cursor keeps blinking in it spot it was on, no obvious change, etc. (no cpu spike or anything)

When pasting via the right click context menu, it works as should be expected.  The contents of the paste buffer are inserted at the cursor (like every standard application).

This bug is in both LO 3.4.5 Release, and 3.5.0 RC2.
Platform: Mac OS X 10.7.3 64-bit
Java: 1.6.0_29 (as built into OS)
Comment 1 Justin Clift 2012-02-06 00:42:37 UTC
This may also be the same bug:

  http://en.libreofficeforum.org/node/235

(I am not the person reporting the problem on that forum)

Click-dragging the text does not work for me. The LO Database window is not a valid paste target. (visually displayed by a "can't paste here" symbol)
Comment 2 Roman Eisele 2012-09-25 08:43:42 UTC
Thank you very much for your bug report!

However, this bug report has never been confirmed by someone else, therefore I have to reset its status to UNCONFIRMED. No offence! This is just how bug wrangling works ;-).
Comment 3 Roman Eisele 2012-09-25 09:15:56 UTC
@ Alex Thurgood:

Hi Alex,
this report reminds me of some other report about a similar issue, but I can’t find it again. You have better knowledge of LibreOffice database issues than me. Can you please check for duplicates (or, if there are no, try if this still reproducible)? You know better which questions to ask if necesary, etc.

Thank you very much!
Comment 4 Alex Thurgood 2012-09-28 11:00:47 UTC
From what I remember there is a general Mac bug with Copy/Paste in Libreoffice that surfaces from time to time. This might be just another case of that particular bug.


Alex
Comment 5 Alex Thurgood 2012-09-28 11:23:43 UTC
In fact, there are several instances within the LibreOffice process where you can not paste via DND or Cmd-V on Mac, most of them are either in Base or in the Basic editor.
Comment 6 Alex Thurgood 2012-09-30 14:51:13 UTC
*** Bug 50479 has been marked as a duplicate of this bug. ***
Comment 7 Alex Thurgood 2012-09-30 15:03:33 UTC
In Mac daily build from 30/09/2012 :

I can :

- drag and drop value from one cell in a grid on a form to a neighbouring cell, so DND works within the Base file itself ;
- right mouse button click Paste

HOWEVER :

I can't Cmd-C/Cmd-V
I can't use the Edit menu to copy and paste either.
I can't undo the DND operation. Pressing Cmd-Z has no effect.
I can't copy/paste from another app, e.g. Firefox, Terminal.app

With Cmd-C/Cmd-V, one can see that the corresponding main menu entry "Edit" is briefly highlighted, but nothing happens.

Confirming.


Alex
Comment 8 Alex Thurgood 2012-09-30 15:09:47 UTC
Not sure whether this is a framework, UI or Base code problem. As it is Mac, will CC Thorsten and Norbert, but it might be the slot identifiers or associated code for Copy/Paste in Mac which are screwed, since I can see the Edit menu highlighted.

@Thorsten, Norbert, Andras : any idea ?

Alex
Comment 9 Roman Eisele 2012-10-01 09:05:23 UTC
@ Alex:

Thank you very much for testing and analysing this issue!
Comment 10 Robert Großkopf 2012-10-08 10:38:34 UTC
*** Bug 52295 has been marked as a duplicate of this bug. ***
Comment 11 Alex Thurgood 2015-01-03 17:41:13 UTC Comment hidden (no-value)
Comment 12 Timothy Harding 2015-03-09 18:59:23 UTC
Confirmed still a problem in Version: 4.4.1.2 on OSX 10.10.2

Ctrl-V highlights the edit menu, but no paste
Edit -> paste also does not work

Interestingly enough
Ctrl-X and
Ctrl-C
both work, I can paste highlighted text in other applications, but paste inside Base still does not work.
Comment 13 frofa 2015-03-10 00:53:26 UTC
Looks like this is a long-existing legacy bug from OpenOffice Base.

REFERENECES:

https://forum.openoffice.org/en/forum/viewtopic.php?f=17&t=30813&p=140418&hilit=Paste+Mac+BASE+problem#p140418

https://bz.apache.org/ooo/show_bug.cgi?id=111775

It would be wonderful if it could be fixed!

NOTE: Pasting using right-click 'paste' command from the drop-down menu works.
Comment 14 frofa 2015-03-10 00:59:58 UTC
Looks like this is a long-existing legacy bug from OpenOffice Base.

REFERENECES:

https://forum.openoffice.org/en/forum/viewtopic.php?f=17&t=30813&p=140418&hilit=Paste+Mac+BASE+problem#p140418

https://bz.apache.org/ooo/show_bug.cgi?id=111775

Pasting in Base using keyboard command or menu has never worked for me (many years). It would be wonderful if it could be fixed!

NOTE: Fortunately, as the original reporter noted, pasting using right-click 'paste' command from the drop-down menu works!
Comment 15 Alex Thurgood 2015-12-09 07:38:31 UTC
*** Bug 89503 has been marked as a duplicate of this bug. ***
Comment 16 Julien Nabet 2015-12-09 08:06:42 UTC
Sorry Alex, I can't help here, it's been long time that I haven't been able to build master sources on MacOs.
I submitted a bugtracker about it, no result yet.
Comment 17 Julien Nabet 2016-06-20 19:07:15 UTC
Alex: with master sources updated 2 days ago, I could paste from a brand new Writer file to a Text box of a form of a brand new HSQLDB file.
I use Cmd-C then Cmd-V

I must recognize, I noticed these on console anyway:
warn:legacy.tools:30531:1:vcl/osx/salmenu.cxx:721: unmapped accelerator key
Comment 18 QA Administrators 2017-09-01 11:19:52 UTC Comment hidden (obsolete)
Comment 19 Stefan vW 2017-10-12 15:15:27 UTC
Bravo! Now it works with LO 5.3.6.1 De language pack on my MacOSX 10.9.5
Comment 20 Alex Thurgood 2017-10-12 16:46:28 UTC
Confirming WFM with 

Version: 5.4.2.2
Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
Threads CPU : 4; OS : Mac OS X 10.13; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group