Download it now!
Bug 45698 - UI: Print icon in Help UI is different to the icon in Standard Toolbar
Summary: UI: Print icon in Help UI is different to the icon in Standard Toolbar
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: x86-64 (AMD64) All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard: target:3.6.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-06 05:44 UTC by Ralph Aichinger
Modified: 2012-05-09 07:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing greyed out icons (12.59 KB, image/png)
2012-02-06 05:44 UTC, Ralph Aichinger
Details
Screenshots (95.23 KB, application/x-download)
2012-04-29 00:00 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralph Aichinger 2012-02-06 05:44:58 UTC
Created attachment 56671 [details]
Screenshot showing greyed out icons

When I open online help, the two icons for Print and Search (a printer and a magnifying glass, respectively) look greyed out. If I click them, they work as expected, though (I can print as well as search). This seems counterintuitive and might fool people.

Debian packages from experimental 3.5rc3 here.

See attachment for screenshot.
Comment 1 Rainer Bielefeld Retired 2012-04-28 10:55:24 UTC
[Reproducible] with Tango Icons "LibreOffice 3.5.3.2 (RC2) English UI/ German Locale [Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80] on German WIN7 Home Premium (64bit), at least for the 'Print' icon. The 'Find' icon has few contrast, but seems to be normal for me also in screenshot.
Galaxy, Crystal, Oxygen do not show that different grey 'Print' icon

Same in old Master builds (2011-11), I believe that nevr has been different

@Ivan:
wiped my glasses, hope this one is true now ;-)
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug
Comment 2 Ivan Timofeev (retired) 2012-04-28 11:43:08 UTC
(In reply to comment #1)
> wiped my glasses, hope this one is true now ;-)

:)

The icon is gray itself. Here it is:
http://cgit.freedesktop.org/libreoffice/core/plain/icon-themes/tango/res/lc05504.png

P.S. The print icon on the standard toolbar is grey as well.
Comment 3 Rainer Bielefeld Retired 2012-04-28 23:59:41 UTC
Yes, I know. It seems the problem is a little more general, there is a related issues with print icon in Tango Theme:

a) we have 2 identical icons for "Print" and "Print Direct", pleas see 
  task bar in screenshots
b) Print icon in Help UI is different to the icon in Standard Toolbar; I doubt that that is intended.

So I think we need an additional different "print direct" icon and we have to modify Icon in Help Tango UI so that it shows the same icon as in Standard Toolbar.
Comment 4 Rainer Bielefeld Retired 2012-04-29 00:00:45 UTC
Created attachment 60757 [details]
Screenshots

comparing icons in different themes
Comment 5 Not Assigned 2012-05-09 05:06:57 UTC
Ivan Timofeev committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=01d3f16e2a4c540b65368a1a94248e324f1d0f73

fdo#45698 - Inconsistent 'Print' icons in Tango theme
Comment 6 Ivan Timofeev (retired) 2012-05-09 05:11:09 UTC
(In reply to comment #3)
> a) we have 2 identical icons for "Print" and "Print Direct"
Can't help with that, sorry.

> b) Print icon in Help UI is different to the icon in Standard Toolbar
Fixed.
Comment 7 Rainer Bielefeld Retired 2012-05-09 07:35:08 UTC
So lets terminate porgrammer's work here, I will follow up the  "identical icons" problem in a new bug.