Bug 45756 - if java is not found, crashed to access java based function.
Summary: if java is not found, crashed to access java based function.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-07 18:46 UTC by sanada
Modified: 2013-01-29 21:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
displayed alert message from 3.5.0. (57.46 KB, image/png)
2012-03-06 18:36 UTC, sanada
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sanada 2012-02-07 18:46:45 UTC
after java settings as default JRE was uninstalled, this event occurs.

CONFIRMATION PROCEDURE

1. install jdk1.6.0_29.
2. boot LibO, select 'LibreOffice' - 'Java' in tree view on displayed dialog, from menubar 'tools' - 'option'.
3. with checked 'Use a Java runtime environment' on the dialog, choose installed 1.6.0_29 JRE at step 1, push OK.
4. once terminate LibO.
5. uninstall jdk1.6.0_29 from OS.
6. install jdk1.6.0_30.
7. reboot LibO, access to java based function.
 * crashed in a trice
e.g. create a new database; push 'Finish' on the Database Wizard, specify the database file in place, push save button...

SUPPLEMENT
about java based function, Base and extenstion correspond.

-----

OS:WinXP(x86) SP3
LibO:3.4.3/3.4.4/3.4.5/3.5.0rc3
Comment 1 sanada 2012-02-07 18:47:17 UTC
for JAPANESE:
------------------
javaが見つからないときにjavaベースの機能にアクセスするとクラッシュする

デフォルトJREとして指定していたjavaをアンインストール後にこの現象が発生する。

確認手順
1. jdk1.6.0_29をインストール
2. LibOを起動し、メニューバー「ツール|オプション」で表示されたダイアログツリービューより「LibreOffice|Java」を選択
3. ダイアログ画面上の「Javaランタイム環境を使用」チェックが付いた状態で、1.でインストールしたJREを選択し、「OK」する
4. LibOを一旦シャットダウンする
5. OSより1.でインストールしたjdkをアンインストール
6. jdk1.6.0_30をインストール
7. LibOを起動し、javaベースの機能にアクセスする
 * この瞬間クラッシュ
例)データベースを新規作成:データベースウィザードより「完了」ボタンを押下し、適当な場所へファイルを指定し「保存」ボタンを押下した瞬間

補足
javaベースの機能とは、Baseやエクステンションが該当します。
Comment 2 sanada 2012-03-06 18:36:51 UTC
Created attachment 58096 [details]
displayed alert message from 3.5.0.

Sorry, I correct it:

----
7. reboot LibO, access to java based function.
 * crashed in a trice
e.g. create a new database; push 'Finish' on the Database Wizard, specify the
database file in place, push save button...
----

crash -> LibO 3.4.5
alert msg -> LibO 3.5.0, 3.5.1 rc1/rc2
Comment 3 Robert Großkopf 2012-06-07 02:07:50 UTC
When the alert occurs in newer version of LO this works for me. It seems to be a bug in earlier versions. The alert is the right answer from base.
Set the Importance to "normal".
Comment 4 Jorendc 2013-01-29 21:56:45 UTC
(In reply to comment #3)
> When the alert occurs in newer version of LO this works for me. It seems to
> be a bug in earlier versions. The alert is the right answer from base.
> Set the Importance to "normal".

Therefore I mark it as WORKSFORME.

@bug reporter (sanada): is it possible to retest this with recenter versions of LibreOffice and Java? If still reproducible, feel free to reopen.

Kind regards,
Joren