Download it now!
Bug 45774 - Resizing .emf picture via relative option distorts the image size.
Summary: Resizing .emf picture via relative option distorts the image size.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: Other All
: low minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:emf
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2012-02-08 05:52 UTC by Poustre Lakos
Modified: 2020-11-09 17:42 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshots (335.31 KB, application/x-gzip)
2012-02-08 07:50 UTC, Poustre Lakos
Details
EMF image (36.40 KB, image/x-emf)
2012-05-29 03:26 UTC, Poustre Lakos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Poustre Lakos 2012-02-08 05:52:32 UTC
Problem description: 
When resizing an image by choosing the percentage option for a SECOND time (the first resize works fine), the image gets distorted.

Steps to reproduce:
1. Right click on image, choose picture and resize by checking "relative" and "keep ratio".
2. The image is resized correctly. Now resize again.
3. Witness the mess.

Current behavior:
When resizing a second time, the image ratio and size go all wrong.

Expected behavior:

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:10.0) Gecko/20100101 Firefox/10.0
Comment 1 Poustre Lakos 2012-02-08 07:50:50 UTC
Created attachment 56753 [details]
screenshots
Comment 2 Poustre Lakos 2012-02-08 07:51:44 UTC
I am testing this with .png images and it does not occur. The bug occurs with .emf images. Resizing by changing inches (i.e not using the relative option) works fine as well.

I have attached three screenshots, one is the initial size (at 61%), second is the first resize (to 76%), and the third is the messed up second resize (to 81%).
Comment 3 sasha.libreoffice 2012-05-16 02:34:57 UTC Comment hidden (obsolete)
Comment 4 Poustre Lakos 2012-05-29 03:26:51 UTC
Created attachment 62197 [details]
EMF image
Comment 5 Poustre Lakos 2012-05-29 03:27:16 UTC Comment hidden (obsolete)
Comment 6 sasha.libreoffice 2012-05-29 03:53:49 UTC Comment hidden (obsolete)
Comment 7 Valek Filippov 2012-07-08 08:53:04 UTC
Reproducible in 3.6beta2.
Offset from expected values seems to be above "rounding" error and overall "relative" makes weird calculations.
Comment 8 QA Administrators 2015-04-19 03:21:14 UTC Comment hidden (obsolete)
Comment 9 Buovjaga 2015-06-15 19:47:36 UTC
(In reply to sasha.libreoffice from comment #6)
> Thanks for attachment
> slightly reproducible in 3.3.4 and 3.5.3 on Fedora 64 bit
> ratio in percents indeed changes slightly each time we resize, but may be it
> is because of rounding number in percents. Especially seen when we change
> width to 1% and second time to 100%. But with png the same.
> I right understand problem?

Yep, repro.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 01a189abcd9a4ca472a74b3b2c000c9338fc2c91
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-14_07:46:28
Locale: fi-FI (fi_FI)
Comment 10 QA Administrators 2016-09-20 10:02:02 UTC Comment hidden (obsolete)
Comment 11 Timur 2020-11-09 14:23:27 UTC
I cannot reproduce even in old LO. Please retest and attach screencast.
Comment 12 Buovjaga 2020-11-09 17:42:20 UTC
Yeah, I can't reproduce either by resizing via the Position and Size dialog and Keep ratio. There is no "relative" option anywhere.

Let's close I guess.

Arch Linux 64-bit
Version: 7.1.0.0.alpha1+
Build ID: c9b320c32aceab7e22d381b688e7b44030e01c2d
CPU threads: 8; OS: Linux 5.9; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 8 November 2020