Bug 45826 - The rtf file is crashing Writer
Summary: The rtf file is crashing Writer
Status: CLOSED DUPLICATE of bug 44736
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected)
3.5.0 release
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Not Assigned
Keywords: regression
Depends on:
Reported: 2012-02-09 03:32 UTC by cristi falcas
Modified: 2012-03-21 22:32 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:

rtf file (182.76 KB, application/x-zip)
2012-02-09 03:32 UTC, cristi falcas

Note You need to log in before you can comment on or make changes to this bug.
Description cristi falcas 2012-02-09 03:32:19 UTC
Created attachment 56808 [details]
rtf file

If you try to open the attached rtf file, libreoffice will use all the memory of the system and will be killed by the OS.

Tested on Ubuntu, Fedora and Windows.

On Ubuntu the machine has 6GB of RAM and 2 GB of swap and they where all eaten by LO.

Not related, but it seems that something very wrong has creeped inside LO. All files seem to load much slower now (on Linux at least) and the conversion to html takes forever. This was not an issue with 3.4.
Comment 1 s-joyemusequna 2012-02-09 05:21:13 UTC
File opens in < 1 sec. in Word 2007, in < 2 sec. in LibO 3.4.5 (Windows Vista 64),
in LibO 3.5 Beta2 I killed the process after several minutes (extreme use of CPU and memory).

This is a regression.

Bug 44736 seems to be related.
Comment 2 Michael Meeks 2012-02-22 03:39:03 UTC

*** This bug has been marked as a duplicate of bug 44736 ***
Comment 3 Jean-Baptiste Faure 2012-03-21 22:32:32 UTC
closing as duplicate.