Download it now!
Bug 45833 - Err:509 on Function Referencing Either Table, Row, Cell Name, or Time Format (?)
Summary: Err:509 on Function Referencing Either Table, Row, Cell Name, or Time Format (?)
Status: RESOLVED DUPLICATE of bug 85063
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-09 05:29 UTC by Scott M. Sanders
Modified: 2016-06-13 20:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Err:509 in Row G (20.81 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.template)
2012-02-09 05:29 UTC, Scott M. Sanders
Details
Err:509 in column G (12.56 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2015-06-16 06:56 UTC, Michael Henke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Scott M. Sanders 2012-02-09 05:29:58 UTC
Created attachment 56816 [details]
Err:509 in Row G

I downloaded an Excel 2007 template from http://office.microsoft.com/en-us/templates/dailyworkprojecthourtracking-TC102031928.aspx that works fine in Excel of course, but in LibO, I get Err:509 for the following function in each data cell of column G, which says simply that an operator is missing:

=Table1[[#this row],[end time]]-Table1[[#this row],[start time]]

In Excel, the function is actually this:

=[@[End Time]]-[@[Start time]]

What it should do is subtract a later time from an earlier time to show the duration between, like 10:00 - 8:00 = 2:00. I'm no function guru so cannot determine what is wrong.

There are various other rendering issues too, but those are other bugs.
Comment 1 sasha.libreoffice 2012-05-16 03:13:01 UTC
Thanks for bugreport
reproduced in 3.3.4 and 3.5.3 on Fedora 64 bit
Changing version to 3.3.4 as most early reproducible
Comment 2 Zeki Bildirici 2013-03-04 19:11:22 UTC
(In reply to comment #1)
> Thanks for bugreport
> reproduced in 3.3.4 and 3.5.3 on Fedora 64 bit
> Changing version to 3.3.4 as most early reproducible

I can reproduce it with LibreOffice 4.0
Changing version to 4.0 release.
Comment 3 sasha.libreoffice 2013-03-05 05:08:22 UTC
But "Version" means that bug appears in this version. It is important to determine when exactly, after which change in program bug appears. And if bug not exist in current version of LO we just close bugreport.
Comment 4 Nicholas 2013-08-20 00:35:46 UTC
It has to do with Structured Reference which I don't think is implemented in Calc (though I could be wrong). I think this would be good idea to be implemented for interoperability with xlsx, obviously after other bugs and features etc.
See:
http://office.microsoft.com/en-001/excel-help/using-structured-references-with-excel-tables-HA010155686.aspx
Comment 5 Eugene Savitsky 2015-02-10 23:26:24 UTC
https://bugs.documentfoundation.org/show_bug.cgi?id=89301

DUP?
Comment 6 Michael Henke 2015-06-16 06:56:39 UTC
Created attachment 116571 [details]
Err:509 in column G
Comment 7 Michael Henke 2015-06-16 07:02:12 UTC
Same issue other File, the file wars created with Office 2007.

LibreOffice
Version: 4.4.3.2
Build ID: 40m0(Build:2)
Ubuntu 14.04 LTS x64
Comment 8 Marcos Marado 2015-09-30 14:31:59 UTC
This *seems* to be the same as #85063 .
Comment 9 raal 2016-06-13 20:28:49 UTC
fixed now, see https://wiki.documentfoundation.org/ReleaseNotes/5.1#Table_structured_references

*** This bug has been marked as a duplicate of bug 85063 ***