Download it now!
Bug 45841 - Autocorrect of single quotes wrong for Maltese Locale
Summary: Autocorrect of single quotes wrong for Maltese Locale
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.3.0
Keywords:
: 73884 94185 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-09 07:43 UTC by Walter
Modified: 2015-09-13 13:31 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Walter 2012-02-09 07:43:09 UTC
When in the Maltese Locale ' ' is automatically corrected to “ ” instead of ‘ ’. I guess that what it entails is to edit the translation tables?

Thanks
Walter
Comment 1 sasha.libreoffice 2012-05-16 03:34:56 UTC
Thanks for bugreport
Please, verify if in last version of LibreOffice still reproducible
Comment 2 Walter 2012-05-16 08:29:52 UTC
(In reply to comment #1)

I Tested the following Portable version of LibreOffice:

LibreOffice 3.5.3.2 
Build ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80 

The bug still exists.

Thanks
Walter
Comment 3 sasha.libreoffice 2012-05-16 22:04:12 UTC
Thanks for additional testing
Comment 4 tommy27 2013-04-27 06:47:09 UTC
I suggest to upgrade to LibO 4.0.2 and see if the issue is still present.

then enter the "tools/autocorrect options" menu and see if there's a corresponding entry in the replacement table, then edit it.

tell us if after editing you still experience that bug.
Comment 5 Walter 2013-04-30 06:21:31 UTC
Yes from the tools/autocorrect options I can choose the quotes I want.

Thanks


On Sat, Apr 27, 2013 at 8:47 AM, <bugzilla-daemon@freedesktop.org> wrote:

>  tommy27 <barta@quipo.it> changed bug 45841<https://bugs.freedesktop.org/show_bug.cgi?id=45841>
>  What Removed Added  CC   barta@quipo.it
>
>  *Comment # 4 <https://bugs.freedesktop.org/show_bug.cgi?id=45841#c4> on bug
> 45841 <https://bugs.freedesktop.org/show_bug.cgi?id=45841> from tommy27<barta@quipo.it>
> *
>
> I suggest to upgrade to LibO 4.0.2 and see if the issue is still present.
>
> then enter the "tools/autocorrect options" menu and see if there's a
> corresponding entry in the replacement table, then edit it.
>
> tell us if after editing you still experience that bug.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 6 tommy27 2013-04-30 07:59:31 UTC
Ok. The issue is solved modifying autocorrect settings.
I change status as RESOLVED NOTABUG
Comment 7 Mihkel Tõnnov 2014-02-12 12:45:54 UTC
Actually, this should be fixed in http://cgit.freedesktop.org/libreoffice/core/tree/i18npool/source/localedata/data/mt_MT.xml#n44 (lines 45 & 46) -- reopening.
Comment 8 tommy27 2014-02-12 12:52:38 UTC
hi which LibO version has that fix?
can anyone try to verify if the bug has gone or not?
Comment 9 Mihkel Tõnnov 2014-02-12 12:58:43 UTC
(In reply to comment #8)
> hi which LibO version has that fix?
> can anyone try to verify if the bug has gone or not?

None. What I meant was that this is the file this "bug" can/should be fixed in.
Comment 10 tommy27 2014-02-12 13:44:44 UTC
(In reply to comment #7)
> Actually, this should be fixed in
> http://cgit.freedesktop.org/libreoffice/core/tree/i18npool/source/localedata/
> data/mt_MT.xml#n44 (lines 45 & 46) -- reopening.

Caolan, could you please take a look at this?
is Mihkel Tõnnov right?
Comment 11 tommy27 2014-02-15 15:54:25 UTC
*** Bug 73884 has been marked as a duplicate of this bug. ***
Comment 12 Commit Notification 2014-02-17 12:24:45 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c20e8fbcf5aa2d358a9bdff2c9adc0b354c3af59

Resolves: fdo#45841 fix autocorrect of single quotes in Maltese



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Julien Nabet 2015-09-13 13:31:06 UTC
*** Bug 94185 has been marked as a duplicate of this bug. ***