Download it now!
Bug 45891 - Changing "control" properties of a widget crashes Libre Office
Summary: Changing "control" properties of a widget crashes Libre Office
Status: RESOLVED DUPLICATE of bug 40261
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-10 05:26 UTC by Dries Feys
Modified: 2012-02-24 07:22 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
file with one text box, one label field, and one label field which is merged to a text-box (9.24 KB, application/vnd.oasis.opendocument.text)
2012-02-10 05:26 UTC, Dries Feys
Details
crash when right click on checkbox and select Control (831.00 KB, video/x-msvideo)
2012-02-24 07:13 UTC, Stefano Fraccaro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dries Feys 2012-02-10 05:26:08 UTC
Created attachment 56864 [details]
file with one text box, one label field, and one label field which is merged to a text-box

When you create a new XML Form, and put a text box on it, there is a grey line around it. When choosing "control" on either a rightclick menu, or the toolbarbutton, the session crashes, not allowing you to change any of the properties.
This might be the same with other types as well.
A workaround to remove the border is to create a Label field first, and replace it with a text box.
Comment 1 Dries Feys 2012-02-10 05:26:57 UTC
This bug also exists in 3.4.4
Comment 2 Stefano Fraccaro 2012-02-24 07:12:00 UTC
This problem happen also with checkbox, radiobutton and other controls.
Comment 3 Stefano Fraccaro 2012-02-24 07:13:06 UTC
Created attachment 57594 [details]
crash when right click on checkbox and select Control
Comment 4 Stefano Fraccaro 2012-02-24 07:16:51 UTC
Seems to be a duplicate of 40261 that is FIXED RESOLVED. It's a regression?
Comment 5 Stefano Fraccaro 2012-02-24 07:21:33 UTC
Jan Holesovsky commited a patch related to this issue to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d5d32eb755c8a53292acbf0648fb82baf6729d8a&g=libreoffice-3-5

fdo#40261: Fix crash in XML Form Document.

*** This bug has been marked as a duplicate of bug 40261 ***
Comment 6 Dries Feys 2012-02-24 07:22:15 UTC
No, it's not a regression : the patch isn't provided yet...
But thanks for the research!! (i searched for my errors, but didn't find it :-/)