Bug 45919 - Access to "Data Range: Area" dialog lost when closing another document
Summary: Access to "Data Range: Area" dialog lost when closing another document
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 45916
  Show dependency treegraph
 
Reported: 2012-02-10 23:52 UTC by Rainer Bielefeld Retired
Modified: 2018-07-14 02:46 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot, Calc without menu bar (100.85 KB, image/png)
2016-04-03 23:11 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-02-10 23:52:00 UTC
Steps how tp reproduce with "LibreOffice 3.5.0 RC3 English UI/Locale [Build-ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735] on German WIN7 Home Premium (64bit) 

1. Launch Calc.
2. Click 'Inserte -> Chart', click <Finish> button in dialog
3. Select the chart(in edit mode), choose 'Data Ranges ...' in context menu.
4. Click icon <Select Data Range>
   > 'Data Range: Area' selector appears, shows data range "$Sheet1.$A$1" 
   or similar
5. Menu 'File -> New -> Spreadsheet'
   > New document appears
6. Close new document and switch back to first Calc document with chart
   Expected: 'Data Range: Area' selector shows data range "$Sheet1.$A$1" 
   Actual: 'Data Range: Area' selector not shown  so
7. Right click into chart for context menu
8. choose 'Data Ranges ...' in context menu.
   > Dialog appears
9. Click icon <Select Data Range>
   Expected: 'Data Range: Area' selector appears
   Actual: Dialog disappears

HANG: from now on there is no possibility to do any further actions, LibO does not respond any longer for this document focus and access get lost, you still can use other opened documents, but you cannot do anything with the test spreadsheet except kill soffice.bin

Same with "LibreOffice Portable 3.3.0  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:6) tag libreoffice-3.3.0.4]", problem seems to be inherited from OOo
Comment 1 Rainer Bielefeld Retired 2012-02-10 23:57:17 UTC
NEW due to AOOo Issue

@Markus:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 2 Markus Mohrhard 2012-03-06 06:11:46 UTC
Ok. I debuged a bit into it and the problem is that the range finder dialog becomes invisble but is still there.

I still could not figure out why this dialog becomes invisble and is not deleted or is still visible.
Comment 3 Jorendc 2014-07-04 18:30:45 UTC
Fail to reproduce, tested using Mac OSX 10.9 with LibreOffice Version: 4.2.5.2
Build ID: 61cb170a04bb1f12e77c884eab9192be736ec5f5
Comment 4 Yousuf Philips (jay) (retired) 2014-07-04 20:57:53 UTC
Confirmed its there in 3.3, 3.6, 4.0, 4.1, 4.2.4, 4.2.6, 4.3.0 and master on Windows and confirmed in on 4.3.0 on Linux Mint. In 4.3 and above, you have to create a data set in order to get it to use data ranges.

Steps to reproduce in 4.3:
1) open calc
2) create a data range like
   A1: Name    B1: Age
   A2: Yousuf  B2: 34
   A3: Joren   B3: 25
3) select A1 to C2
4) click the chart button in the standard toolbar
5) click the next>> button in the chart wizard dialog to get to data range
6) click on the 'select data range' button to the right of the data range field
7) 'Data Range: Area' dialog appears
7) goto File > New > Spreadsheet
8) close the newly opened Spreadsheet
9) 'Data Range: Area' dialog is gone

You will not be able to close LibO after step 9 as the close and exit file menu items are dimmed, which also makes the 2 close buttons in the top right corner also not function. You wont be able to bring back up the 'Data Range: Area' dialog by right-clicking the chart, selecting 'Data Ranges...', and then clicking the 'select data range' button.
Comment 5 QA Administrators 2015-07-18 17:42:35 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2015-10-16 19:12:45 UTC
Still repro.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 186f32f63434e16ff5776251657f902d5808ed3d
TinderBox: Win-x86@39, Branch:master, Time: 2015-10-16_09:42:47
Locale: en-US (fi_FI)
Comment 7 Terrence Enger 2016-04-03 02:17:17 UTC
In the daily Linux bibisect repository version 2016-04-02, I see that the program removes the menubar from the window during the Chart Wizard and while the chart is selected.  Thus there is no way to do Step 5.

I am setting bug status RESOLVED WORKSFORME.
Comment 8 Buovjaga 2016-04-03 11:51:34 UTC
(In reply to Terrence Enger from comment #7)
> In the daily Linux bibisect repository version 2016-04-02, I see that the
> program removes the menubar from the window during the Chart Wizard and
> while the chart is selected.  Thus there is no way to do Step 5.
> 
> I am setting bug status RESOLVED WORKSFORME.

I could repro steps from comment 4. Please use them.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.0.alpha0+
Build ID: 9b0069c2833313ba9fab91f45edd354ba334f94b
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on April 3rd 2016
Comment 9 Terrence Enger 2016-04-03 23:11:01 UTC
Created attachment 124048 [details]
screenshot, Calc without menu bar

Thank you, Buovjaga.

We are using different distributions desktop managers.  That might be the source of the difference.  I lack the knowledge to investigate further.
Comment 10 Buovjaga 2016-04-04 05:34:48 UTC
(In reply to Terrence Enger from comment #9)
> Created attachment 124048 [details]
> screenshot, Calc without menu bar
> 
> Thank you, Buovjaga.
> 
> We are using different distributions desktop managers.  That might be the
> source of the difference.  I lack the knowledge to investigate further.

Yeah, I also still repro on Windows.

The only way to be able to exit LibO again is to delete the chart, start the chart wizard again and cancel out of it.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 7a7be32e5265f897174f3880adc061dac0203f1f
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-03-31_07:39:11
Locale: fi-FI (fi_FI)
Comment 11 Terrence Enger 2016-04-07 14:57:04 UTC
Just a note:  With commit 95b720f, fixing bug 98783 "gtk3: menubar is missing when editing object", I can now open a new spreadsheet while the Data Ranges dialog is open.  However that dialog is still visible when I close the new spreadsheet.  

This is with daily Linux dbgutil bibisict repository version 2016-04-07 running on debian-stretch.
Comment 12 QA Administrators 2017-05-22 13:21:47 UTC Comment hidden (obsolete)
Comment 13 Xisco Faulí 2017-07-13 10:15:08 UTC
Setting Assignee back to default. Please assign it back to yourself if you're
still working on this issue
Comment 14 QA Administrators 2018-07-14 02:46:42 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug