Download it now!
Bug 45953 - Incorrectly printing of documents when paper size in LO is not the default of the printer
Summary: Incorrectly printing of documents when paper size in LO is not the default of...
Status: RESOLVED DUPLICATE of bug 33791
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: x86 (IA32) Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-12 05:54 UTC by Matthias Pronk
Modified: 2012-05-17 06:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
LO vs Preview.app on Mac OS X, Preview allows selecting the paper size. (345.78 KB, image/jpeg)
2012-02-12 05:54 UTC, Matthias Pronk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Pronk 2012-02-12 05:54:50 UTC
Created attachment 56915 [details]
LO vs Preview.app on Mac OS X, Preview allows selecting the paper size.

LibreOffice does not allow specifying a different paper size in the Mac OS X printing dialog. Because of this, when you are printing a document in LibreOffice which has not the same paper size as the default paper size of the printer (as specified in the Mac OS X printer setup), the document will be incorrectly printed (clipping occurs).

Preview, an application shipped with Mac OS X, allows you to specify the paper size in the printing dialog. For a comparison between the LibreOffice printing dialog and the Preview printing dialog see attached screenshot.
Comment 1 Matthias Pronk 2012-04-05 00:44:27 UTC
Please note, saving the document as PDF and printing from Preview.app works fine as a workaround. However, this will confuse and frustrate a lot of new users.
Comment 2 lauregl 2012-04-19 04:33:57 UTC
I think this is normal LO behavior, paper size is selected in Format/Page menu
Comment 3 Matthias Pronk 2012-04-19 23:57:54 UTC
@ lauregl@gmail.com
Yes, you can select the paper size in the Format/Page menu. However, I think this information is not "send" to the printer driver, because the printer output is clipped.
If the paper size would be correctly recognized by the printer driver I don't think there would be any problem.
Comment 4 sasha.libreoffice 2012-05-17 06:09:28 UTC
Thanks for bugreport. Looks like duplicate of Bug 44664
Comment 5 Matthias Pronk 2012-05-17 06:38:25 UTC
Reading through the bug you've mentioned and the comments of various bugs, I think it's actually a duplicate of #33791.

*** This bug has been marked as a duplicate of bug 33791 ***