Bug 46009 - : Slow LibreOffice Base
Summary: : Slow LibreOffice Base
Status: RESOLVED DUPLICATE of bug 35023
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: x86-64 (AMD64) macOS (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-13 12:41 UTC by Miguel
Modified: 2012-02-13 14:14 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miguel 2012-02-13 12:41:44 UTC
Problem description: 

Steps to reproduce:
1. .... access to a MySQL server (5.1.49-3 (Debian)) over a ssh tunnel with the option MySQL (JDBC). The ssh tunnel is through Internet and both server and client are behind an ADSL router.
2. .... open a table with about 70 fields and 900 rows
3. .... wait for 15s to see the first 34 rows. Then about 1s after every attempt to scroll down the list to see about 10 more rows.

Current behavior:
About 15s to view a 900-rows table

Expected behavior:
Faster load time and snappier scrolling of the table. Using MySQLWorkBench with the exact same setup (ssh tunnel) load times are 1 or 2 seconds and I can scroll the 900 rows snappily.

I've found similar reports here:
http://ubuntuforums.org/showthread.php?t=1693148
But it's a bit difficult to change or downgrade Java version under Mac OS X

Platform (if different from the browser): 
Java 1.6.0_29 (included in Mac OS X 10.7.3)
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_3) AppleWebKit/534.53.11 (KHTML, like Gecko) Version/5.1.3 Safari/534.53.10
Comment 1 Rene Engelhard 2012-02-13 14:14:04 UTC
this is already fixed in 3.5.0 (since 3.5.0 beta3).

(see Bug 35023)

*** This bug has been marked as a duplicate of bug 35023 ***