Bug 46016 - When recording a macro with date or time in it you get numbers instead of the date or time
Summary: When recording a macro with date or time in it you get numbers instead of the...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
(earliest affected)
3.4.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
: 46032 (view as bug list)
Depends on:
Blocks: Macro-Recording
  Show dependency treegraph
Reported: 2012-02-13 22:18 UTC by Steve
Modified: 2020-11-01 13:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Note You need to log in before you can comment on or make changes to this bug.
Description Steve 2012-02-13 22:18:29 UTC
I noticed when recording and then running macros with the date or time in them, you got numbers in them instead of the date or time in the format you chose when you run the macro in a Writer document.

I was told in a forum that these numbers are the 'internal decimal representation' or something.  If you do a macro to enter a fixed date for example, you get the numbers.  If you hit Ctrl F9 it shows "Date (fixed)".  You can toggle back and forth between the numbers and "Date (fixed)" by hitting Ctrl F9 over and over.

This doesn't happen in LibreOffice on Win 7, I have it installed there too, and the macro records and works as intended there.

As further information, I ran into this problem years ago with OpenOffice when I was running it under Win XP.
Comment 1 Steve 2012-02-14 04:52:47 UTC
I posted a new bug report, because I clicked on bug on the LibreOffice.org site and it brought that up instead of this bugzilla page.  As I said in the other report, I have been checking this out in my Linux Mint 12 KDE and Win 7 installs, dual boot on the same laptop.  Macro recording works fine in Win 7 and does this bug in Mint.  I had an idea and followed up on it.  So I guess you can delete the other new bug report I filed or whatever you do with duplicate reports.  Sorry, like I said it didn't bring up this page so I could find this original report.

I'm almost sure it's a bug in the Linux implementation, or a missing library, something.  I followed up on an idea, switched from my Linux to my Win 7 and pulled up the Macro Organizer.  I selected one of the macro's and clicked the Edit button.  It opened up the Macro Editor window, and I was surprised to see how long it was, the macro was just for inserting date and time formatted the way I wanted on a line.  I was just going to copy over the code for one macro and do some testing.  I got to looking, all of my macros were in this file!  Was [My Macros & Dialogs].standard in the editor.  So, I copied everything from the window to a text file.

I switched back to my Linux install and pulled up the Macro Organizer, and then pasted in the text from over in Win 7.  Closed that window.  Sure enough, it listed all the macros from over in the Win 7 install.  I tried some of them out.  The one for my standard footer worked, text with page number and page count.  The one for date and time worked like it had in Windows, centering the text, separating it by a number of tabs, but both date and time weren't the date and time for when I clicked on the macro, they were the number 40953.25.  I tried to select them, just backspace over and see what would happen, wouldn't do it.  Instead, when I right clicked on one of them it brought up a window titled Edit Fields:Document.

In this box were buttons with left and right arrowheads.  When the date one was selected it showed the date type it was, date, Date (fixed), and the format I had selected.  When I clicked on the other button it selected the time field and showed the time type it was - time, Time (fixed), and the format I had selected.

So anyway, same macro code on Win 7 side and Linux Mint side.  Does the macros fine in Win 7 but in Linux Mint gives these fixed identifier numbers instead of the fixed date and time like it should.
Comment 2 Steve 2012-02-14 04:55:20 UTC
*** Bug 46032 has been marked as a duplicate of this bug. ***
Comment 3 QA Administrators 2014-10-24 03:18:20 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2015-12-20 16:12:43 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-01-03 19:48:06 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2020-10-21 04:22:46 UTC
Dear Steve,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword

Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team