Bug 46024 - [RFE, FORMATTING] Allow creation of floating paragraphs
Summary: [RFE, FORMATTING] Allow creation of floating paragraphs
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Paragraph Writer-Styles-Paragraph Writer-Enhancements
  Show dependency treegraph
 
Reported: 2012-02-14 01:53 UTC by Nicolas Mailhot
Modified: 2021-04-14 10:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Mailhot 2012-02-14 01:53:40 UTC
It is very common to put some special text inside a frame or with a special background to the right, the left or the middle of the document

In that case the text behaves like a picture

It should be possible to add a float property to paragraph styles (with a width) to allow clean handling of such cases without needing to add a frame manually that breaks the editing workflow

That would also improve compatibility with html import/exports

Floating could also be used to implement the kind of document, that uses a large left margin, and puts section titles there (next to the section text, not over the section text). This is common in huge technical or legal documents :

2.1.1 Section title   The section text continues to the right of the title
      is here         and not under it like it's usually done
Comment 1 Joel Madero 2012-08-07 14:52:25 UTC
I am going to confirm that this is an enhancement request but I want to let you know that in my opinion it's very unlikely that this will be implemented any time soon. Our team is stretched really thin and because there is a "normal" workaround (ie frame that you can use), the difficulty of implementation, and the number of users who would benefit, it's going to be marked as a low priority. I know that these things are subjective but with thousands of bugs on the list I hope you understand :)

I'm not even sure how we could implement it so that it's easier to use than a frame but I'll leave that in the hands of one of the developers if/when they see it. Thanks for reporting and please continue to help us improve LibreOffice :)
Comment 2 Nicolas Mailhot 2012-08-19 08:27:29 UTC
Thank you

There is no 'normal' workaround, frames are hell to use except in toy documents with a handfull of titles only

This RFE intends to make it a paragraph style property, which *is* a lot easier to use (and change) than frames that all need manual positionning
Comment 3 Buovjaga 2021-04-14 08:27:43 UTC
Design team: this needs to be re-evaluated
Comment 4 Heiko Tietze 2021-04-14 10:43:00 UTC
We have to follow the ODF standard and floating text is not part of it. Besides, I believe all formatting can be done easily with what we have, the two columns example is one out of the box, and frames are handy for unusual situations with freely positioned text. => WF