Download it now!
Bug 46053 - IME - telugu input of 'combined characters' is causing LibreOffice to crash
Summary: IME - telugu input of 'combined characters' is causing LibreOffice to crash
Status: RESOLVED DUPLICATE of bug 45355
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-14 10:11 UTC by Raju Chitrada
Modified: 2012-10-18 15:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raju Chitrada 2012-02-14 10:11:54 UTC
Problem: LibreOffice not working with IME (I tested with Telugu)

Details: In any type of document in LibreOffice (Text/Spreadsheet/HTML/...) if we input anything in Telugu (te) using any IME (I tesed with Google Input and Baraha IME), it crashes. It does work when single characters are entered (example: అ, గ), but when ‘2 characters that get combined’ are entered (example: గి, మే) then LibreOffice crashes.

Environment:
    LibreOffice 3.4.3
    Win 7 Pro
    Google Input (or) Baraha IME 10.2
Comment 1 dE 2012-08-28 14:36:25 UTC
Do you have the fonts somewhere?


This's not a critical bug as not many users are affected.
Comment 2 Raju Chitrada 2012-09-02 15:42:02 UTC
Thanks dE!

Yes, I have the fonts installed on my machine (I think, I received them part of installing Win-7 with language support for Indian languages).

A note may help you to diagnose quicker - the IME input is working well with other applications like Notepad but fails with LibreOffice.
Comment 3 Caolán McNamara 2012-09-04 12:31:31 UTC
Hopefully this is a duplicate of bug 45355 believed fixed by http://cgit.freedesktop.org/libreoffice/core/commit/?id=c5df4ffdab3a66508b6e259703b77979a2733401&g=libreoffice-3-6

If that's the case then this should work fine in LibreOffice 3.6.1. Can you try that and see if the problem still persists, or if it's fixed there.
Comment 4 Caolán McNamara 2012-10-18 15:18:41 UTC
will assume it is a duplicate

*** This bug has been marked as a duplicate of bug 45355 ***