Bug Hunting Session
Bug 46098 - EDITING Copy part of the cell content freeze Calc for a few seconds
Summary: EDITING Copy part of the cell content freeze Calc for a few seconds
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-15 05:03 UTC by ktos.obcy+freedesktop
Modified: 2014-09-25 21:25 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ktos.obcy+freedesktop 2012-02-15 05:03:42 UTC
Steps to reproduce:
* Write something into cell and approve it (e.g. [enter])
* Select same cell and either go into edit or simple select part of the text in the formula toolbar (doesn't matter if it is whole content [ctr+a] or only part)
* Try to copy it (either context menu or [ctr+c])

value is properly copied, but there is a noticeable (few seconds) lag and UI freeze.
Comment 1 ktos.obcy+freedesktop 2012-02-15 05:05:33 UTC
I've noticed it in Calc at least 3.4 (not sure if previous is applicable) and it still can be reproduced in the 3.5.0.
Comment 2 ktos.obcy+freedesktop 2012-03-15 07:00:54 UTC
Still persists in the latest release.
Comment 3 e325001 2012-06-20 08:49:42 UTC
Possible dupe of bug https://bugs.freedesktop.org/show_bug.cgi?id=45596
Comment 4 A (Andy) 2014-09-24 21:24:57 UTC
for me not reproducible with LO 4.3.1.2 (Win 8.1)

Is this for you or anybody else still reproducible with the latest release of LO?  Otherwise, we can maybe close this issue.
Comment 5 ktos.obcy+freedesktop 2014-09-25 06:24:08 UTC
I haven't encountered the issue for a while now (maybe since 4.1 release) so I'm in favour of closing it.
Comment 6 A (Andy) 2014-09-25 21:25:34 UTC
Thank you very much for your fast reply.