Bug 46119 - computeFunction method error (GeneralFunction.VAR, VARP, STDEV and STDEVP)
Summary: computeFunction method error (GeneralFunction.VAR, VARP, STDEV and STDEVP)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Eike Rathke
URL:
Whiteboard: target:6.3.0 target:6.2.0.1
Keywords:
: 39045 (view as bug list)
Depends on:
Blocks: Macro-UNOAPI
  Show dependency treegraph
 
Reported: 2012-02-15 09:13 UTC by blargh
Modified: 2019-11-22 09:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Spreadsheet with a macro using the mentioned corrupted computeFunctions (16.99 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-02-15 09:13 UTC, blargh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description blargh 2012-02-15 09:13:07 UTC
Created attachment 57108 [details]
Spreadsheet with a macro using the mentioned corrupted computeFunctions

computeFunctions:
  com.sun.star.sheet.GeneralFunction.VAR
  com.sun.star.sheet.GeneralFunction.VARP
  com.sun.star.sheet.GeneralFunction.STDEV
  com.sun.star.sheet.GeneralFunction.STDEVP
returns approximately zero when applied to a cell range.

(but com.sun.star.sheet.GeneralFunction.MAX, MIN, AVERAGE and SUM are working properly)

It has also been reported here: http://openoffice.org/bugzilla/show_bug.cgi?id=101713
Comment 1 blargh 2012-02-15 09:15:18 UTC
*** Bug 39045 has been marked as a duplicate of this bug. ***
Comment 2 sasha.libreoffice 2012-05-21 03:04:46 UTC
Thanks for bugreport.
Reproduced in 3.5.3 on Fedora 64 bit
Comment 3 blargh 2013-08-23 12:56:15 UTC
Reproduced in LibreOffice 4.1.0.4 on Windows 7.
Comment 4 pierre-yves samyn 2013-12-07 15:31:11 UTC
Hello

I confirm on windows 7/64 with

Version: 4.1.3.2
Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

Version: 4.2.0.0.beta2
Build ID: 1a27be92e320f97c20d581a69ef1c8b99ea9885d

I add to the list: com.sun.star.sheet.GeneralFunction.PRODUCT
(does not work)

Regards
Pierre-Yves
Comment 5 QA Administrators 2015-04-19 03:22:51 UTC Comment hidden (obsolete)
Comment 6 pierre-yves samyn 2015-04-19 06:45:21 UTC
Hi

Still reproduced on windows 7/64 & Version: 4.4.3.1
Build ID: b2f347f2ac68821efc00b6f1793cda90af748118
Locale: fr_FR

Regards
Pierre-Yves
Comment 7 QA Administrators 2016-09-20 09:24:21 UTC Comment hidden (obsolete)
Comment 8 blargh 2016-09-20 20:31:52 UTC
Big is still present on LibreOffice 5.2.2.1, Windows 7/64.
Comment 9 Xisco Faulí 2017-09-29 08:52:47 UTC Comment hidden (obsolete)
Comment 10 blargh 2017-10-01 15:53:41 UTC
Big is still present in LibreOffice 5.4.1.2, Windows 7/64 and Ubuntu 16.04.
Comment 12 Eike Rathke 2018-12-10 22:26:08 UTC
Seems these were never implemented.
Comment 13 Commit Notification 2018-12-11 16:55:44 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/fc1568d570a96bfa57013ae62adf3f9606639fd3%5E%21

Resolves: tdf#46119 implement GeneralFunction_VAR, VARP, STDEV and STDEVP

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Eike Rathke 2018-12-11 16:56:37 UTC
Pending https://gerrit.libreoffice.org/64975 for 6-2
Comment 15 Commit Notification 2018-12-11 21:24:58 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/1cb79dd63e0f825cee46fa58a6a9df39e8160f60%5E%21

Resolves: tdf#46119 implement GeneralFunction_VAR, VARP, STDEV and STDEVP

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.