Bug Hunting Session
Bug 46146 - UI: Regression: Can't open "Last documents used"
Summary: UI: Regression: Can't open "Last documents used"
Status: RESOLVED DUPLICATE of bug 46074
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-15 23:28 UTC by Victor V. Terber
Modified: 2012-03-21 13:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor V. Terber 2012-02-15 23:28:34 UTC
Problem description: 

Steps to reproduce:
1. Upgrade LO 3.4.5 (German) to 3.5 (German)
2. Open a document. Close the document
3. Select "File"/"Open last used documents" (or something similar, I'm using the German translation which states "Zuletzt benutzte Dokumente...")

Current behavior:
LO shows "No Documents" ("Keine Dokumente")

Expected behavior:
LO should show the list of last documents used. Worked nicely in all previous versions. Doesn't work in Writer too.


Platform (if different from the browser): 
Windows Vista 7 Ultimate, fully patched, German locale
     
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 Victor V. Terber 2012-02-18 10:23:49 UTC
The bug appears when upgrading from 3.4.5 to 3.5.

The bug was independently confirmed several times, also on Linux/Kubuntu, see for instance:

http://article.gmane.org/gmane.comp.documentfoundation.libreoffice.discuss.german/11073
http://comments.gmane.org/gmane.comp.documentfoundation.libreoffice.discuss.german/11070
http://svenseidel.net/blog/2012/libreoffice-neue-testversion-3-5/

What workaround exists besides creating a completely new profile (which would loose all the other data)???
Comment 2 Emerson 2012-03-01 09:21:43 UTC
This bug is on 3.5.0rc3 portuguese (brazilian) version as well.

Windows 7; 32-bit; Portuguese - Brazilian
Comment 3 Victor V. Terber 2012-03-19 03:30:25 UTC
I now de-installed LO 3.5, and afterwards installed LO 3.5.1.

Still the same problem.

As this problem is obvious, and was observed and discussed by numerous users on the net, I can't understand, why it isn't triaged into a higher priority, and why there isn't any reaction at all by any developer or tester...
Comment 4 sasha.libreoffice 2012-03-21 09:32:46 UTC
Thanks for bugreport
Sorry, but I can not reproduce this in 3.5.1 upgraded from 3.4.3 on Windows XP 32 bit Russian locale

To fix this problem, developers needed profile where this bug is reproducible. Please, find or produce profile where is no secret information, but this bug is reproducible. Then archive (zip) it and attach to this bugreport or email to me.

May be problem is inside of file registrymodifications.xcu (inside of profile)
Try move it in another place and see if problem remains or disappears. If problem is in this file, please, attach this file instead of all profile.
Comment 5 Victor V. Terber 2012-03-21 13:53:13 UTC

*** This bug has been marked as a duplicate of bug 46074 ***