Bug Hunting Session
Bug 46199 - Can't install due to false detection of quickstarter or open previous version
Summary: Can't install due to false detection of quickstarter or open previous version
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-16 15:51 UTC by Alan Hadsell
Modified: 2012-03-20 03:44 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Hadsell 2012-02-16 15:51:07 UTC
Problem description: 

The installer detects an open instance of the suite, or the quickstarter, when none is present.


Steps to reproduce:
0. Open LibO 3.4, deselect Quickstarter in the options, log out and log in again.  Verify that quickstarter is not running by looking at Task Manager.
1. Start installation
2. Select Custom
3. Deselect all dictionaries except English
4. Deselect Quickstarter
5. Deselect PDF Import and MediaWiki Publisher
6. Select default application for all types (Word, Excel, PPT)
7. Proceed with installation 

Current behavior:

Dialog is displayed:

Please exit LibreOffice 3.4 and the LibreOffice 3.4 Quickstarter before you continue.  If you are using a multi-user .....

Expected behavior:

Installation completes normally.

Platform (if different from the browser): 

Windows 7, 64-bit
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Comment 1 Andras Timar 2012-02-24 03:28:47 UTC

*** This bug has been marked as a duplicate of bug 36677 ***
Comment 2 Eric Schwarzenbach 2012-03-07 12:55:06 UTC
This bug is NOT a duplicate of bug 36677. This bug is *caused* by that bug which has been fixed in 3.5, but THIS bug is NOT fixed in 3.5: it continues to be a problem in 3.5 due to the other bug not having yet been fixed in previous versions. The comments in THAT bug would seem to suggest that THIS bug cannot be fixed. 

If your software uses a component, and that component has a bug, then your software has a bug! The 3.4 uninstaller (when that is installed) is essentially being used as a component by the 3.5 installer.

Simply from a practical standpoint, you don't want users not to be able to find this issue because they are searching for an issue that are having with 3.5 and you closing 3.5 issues for this as duplicate or fixed.
Comment 3 Andras Timar 2012-03-20 03:44:17 UTC
I'm not interested in lectures of formal logic. I'll close this as WONTFIX, if you like it more. This bug will automatically disappear in a few months - when everybody out there has upgraded, and I don't think I should waste more time on "fixing" it.