Download it now!
Bug 46264 - 64 Bit: Java runtime not recognized
Summary: 64 Bit: Java runtime not recognized
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-18 13:32 UTC by peter Roots
Modified: 2012-04-27 00:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peter Roots 2012-02-18 13:32:05 UTC
Problem description: on installing LO3.5 on 64bit Kubuntu 11.10 I noticed an error, something to the effect that no jre was found. After installation completed I looked in Tools>Options>Java and no jre was shown. 
I chose to add one and selected /usr/lib/jvm/java-6-openjdk/jre only to be told "the folder you selected does not contain a java runtime environment." (Same with java-1.6.0-openjdk/jre and default-java/jre)
I then reinstalled LO3.4 (which I had removed prior to installing 3.5)and checked to see where it had found a jre - it was the path used above ie /usr/lib/jvm/java-6-openjdk/jre.
I read somewhere that LO3.5 works with java 7 so installed openjdk 7 and tried /usr/lib/jvm/java-7-openjdk-amd64/jre (and java-7-openjdk-common/jre) neither of which worked either

Current behavior: LO3.5 tells me I have no jre

Expected behavior: that LO3.5 would use the same jre as LO3.4 does

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.7 (KHTML, like Gecko) Ubuntu/11.10 Chromium/16.0.912.77 Chrome/16.0.912.77 Safari/535.7
Comment 1 peter Roots 2012-02-18 14:05:27 UTC
Tried a reinstall and the error, during install was
javaldx: Could not find a Java Runtime Environment!
which followed each of the dictionary installs (although spell checking works)
Comment 2 peter Roots 2012-02-23 13:24:34 UTC
I have removed 3.5 totally, including config files.
Removed 3.4 (left config)
reinstalled 3.5 - still not finding java
reinstalled 3.4 installs without problem

tried an install of 3.5 on a VM running Linux mint 11 (32bit) with 3.4 installed. Installed without problem.
Comment 3 Erich 2012-02-26 16:12:09 UTC
Confirm with 3.5.1.1 RC1 on Win7-64 (3.5.0 update)

LO is looking for the wrong path to the location of Java64 at
./user/Program Files(x86)/Java
instead of user/Program Files/Java where the 32bit version sits.

Have to choose subfolder ./Java/jre6 on [Add], otherwise error:
This folder does not contain a Java Runtime Environment.

Possible enhancement:

Clicking [Add] should not open dir-tree at "My Documents" but rather collapsed or focus at Program Files/Java to ease the choice and identify potential subfolders of /Java.
Comment 4 peter Roots 2012-02-27 13:55:19 UTC
Just fixed this. I don't recall being given a choice when I first downloaded LO3.5 but I got the i386 version. Today I downloaded again and got the 64bit version (defaulted to that, no offer of i386).
After removing the old and installing the new all is now working as it should.
Comment 5 Rainer Bielefeld Retired 2012-04-26 23:46:13 UTC
Closing due to Comment 4