Bug Hunting Session
Bug 46272 - VIEWING: Shape "Circular Arrow" looks distorted
Summary: VIEWING: Shape "Circular Arrow" looks distorted
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium normal
Assignee: Lennard Wasserthal
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-18 22:43 UTC by Rainer Bielefeld Retired
Modified: 2013-11-15 20:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document with screenshots (60.02 KB, application/vnd.oasis.opendocument.graphics)
2012-02-18 22:43 UTC, Rainer Bielefeld Retired
Details
pdf file showing incorrect shapes (101.33 KB, application/pdf)
2012-10-21 09:12 UTC, luksiw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-02-18 22:43:38 UTC
Created attachment 57265 [details]
Sample document with screenshots

Arrowhead of Block Arrow shape "Circular Arrow" in document from 3.4.5 looks wrong in 3.5.4 and Master, compare views in attached sample document.

It's not necessary to do all steps as you see in sample, you can simply insert the shape with 3.5.0 and move the yellow control point at the arrowhead.

Was ok until Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID: 81607ad-3dca5fd-da627d2)]"

Prolbem starts for me with parallel installation of MinGW Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID: 308b7a2-e916bf9-9c6ea62-e1a2fb3)] (daily/MinGW_cross-compilation 2011-10-18_22.56.49)"
Comment 1 Lennard Wasserthal 2012-09-02 17:15:02 UTC
This appears only on those which are scaled differently on x and y.
This has to do something with the circular arcs.
They are always drawn so that the tangents' angles of the arc ends follow the scale warp.
Comment 2 Lennard Wasserthal 2012-09-02 17:19:32 UTC
Effect Also to be seen on pacman shape and ordinary arc.
Comment 3 Lennard Wasserthal 2012-09-23 17:10:55 UTC
I found out where the bug is.
Location: ./svx/source/customshapes/EnhancedCustomShape2d.cxx
procedure: EnhancedCustomShape2d::CreateSubPath
case: QUADRATICCURVETO
The multiplier fRatio is totally contraproductive. Why is it there??
No distortion without it.
Patch comes after further testing.
Comment 4 luksiw 2012-10-21 09:12:17 UTC
Created attachment 68863 [details]
pdf file showing incorrect shapes

Issue still exists for Version 3.6.4.0+ (Build ID: d401dcc)
Build: libreoffice-3-6~2012-10-19_19.11.54_LibO-Dev_3.6.4.0_Win_x86_install_en-US.msi
OS: Win XP
Comment 5 Lennard Wasserthal 2012-10-21 18:05:50 UTC
@ luksiw@gmail.com I dont get it. I got the latest master, but my code change is still there.
A master two weeks old still works.
May this have to do something with that it was not TAKEN OVER to the windows version repository, or did you compile it from master by yourself????
(Because I removed something in this patch that noone knew what it was for, there was a fear of a regression.)
I cannot compile the current version until I download it new, but I found no newer patch entry that could have done bad things to this. (my change is still the latest in that file, d9f21c90bd61d15fd78a8df9115bf2e9ededbd1b).
Comment 6 luksiw 2012-10-21 18:31:40 UTC
(In reply to comment #5)
> May this have to do something with that it was not TAKEN OVER to the windows
> version repository, or did you compile it from master by yourself????

Yes, I believe that is the reason. I tried to reproduce the bug in a version I compiled myself (Version 3.7.0.0.alpha0+ (Build ID: 370m0(Build:0))) and not the one I got from repository and it's working perfectly fine, no distortions. Sorry for causing unnecessary confusion.