Download it now!
Bug 46343 - FORMULAEDITOR: Add the tensor product operator into "Elements" pane
Summary: FORMULAEDITOR: Add the tensor product operator into "Elements" pane
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Takeshi Abe
URL:
Whiteboard: BSA target:4.5.0
Keywords:
: 58054 (view as bug list)
Depends on:
Blocks: Elements-Pane
  Show dependency treegraph
 
Reported: 2012-02-20 06:46 UTC by collette
Modified: 2016-10-24 13:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description collette 2012-02-20 06:46:58 UTC
Add the tensor product operator.
This operator corresponds to a circle with a cross inside.
The at http://en.wikipedia.org/wiki/Tensor_product

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 5.2; WOW64; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Comment 1 sasha.libreoffice 2012-05-22 09:16:02 UTC
Thanks for new idea
In 3.5.3 I can not find this character in formula editor, supposing not implemented yet and changing status to NEW

PS: Interesting, what ODF standard tells about it?
Comment 2 Roberto 2012-08-14 22:14:16 UTC
(In reply to comment #0)
> Add the tensor product operator.
> This operator corresponds to a circle with a cross inside.
> The at http://en.wikipedia.org/wiki/Tensor_product
> 
> Platform (if different from the browser): 
> 
> Browser: Mozilla/5.0 (Windows NT 5.2; WOW64; rv:10.0.1) Gecko/20100101
> Firefox/10.0.1

Dear Collette:

Dis you tried with otimes?

1.- Open L.O: Math
2.- Write this commands:
V otimes W.


Kind regards.

Roberto.
Comment 3 sasha.libreoffice 2012-08-15 10:08:16 UTC
Thanks for useful information.
As I can see, it works. But how to place it by mouse? Enhancement is still actual.
Comment 4 Roberto 2012-08-16 23:24:12 UTC
(In reply to comment #3)
> Thanks for useful information.
> As I can see, it works. But how to place it by mouse? Enhancement is still
> actual.

Yes, you're right. It's impossible to put the tensor product operator inside a formula using only mouse. Moreover, if you don't know that 'otimes' command exists, you probably will think that's there is no way to introduce the tensor product operator inside any formula created with Math. But I must say that this problem doesn't affect 'otimes' only. If you chek out the LibreOffice Math Guide for version 3.5 (available from http://www.libreoffice.org/get-help/documentation/), you will find many 'characters' and attributes that you only can insert if you know the corresponding command (page 35, Math commands - Reference).
In this sense, Math needs a big improvement (apart from symbols that Math sill lacks).

Kind regards.

Roberto.

P.S. please, sorry for my absolutely terrible English in my last comment.
Comment 5 Jorendc 2013-01-28 20:01:00 UTC
*** Bug 58054 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2015-02-27 12:10:11 UTC
Takeshi Abe committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2459936cda33fb0ec7aecad9b8cbde8cd6a84cfb

tdf#46343: Add the tensor product operator to "Elements Dock"

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.