Bug Hunting Session
Bug 46377 - : BASISINSTALLLOCATION points to a non-existing location
Summary: : BASISINSTALLLOCATION points to a non-existing location
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All Windows (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: BSA target:3.6.0 target:3.5.1
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-21 01:41 UTC by Martho
Modified: 2012-04-05 08:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martho 2012-02-21 01:41:01 UTC
Problem description: 
In the registry, the key BASISINSTALLLOCATION is set to C:\Program Files\LibreOffice 3.5\Basis\. But this folder isn't created during the installation in this version (it was created in previous versions). This ends up in problems with 3rd-party scripts which are relying on this registry value (for example scripts that setup the environment for the SDK).

Steps to reproduce:
1. Install this version on windows

Current behavior:
The key BASISINSTALLLOCATION points to C:\Program Files\LibreOffice 3.5\Basis\

Expected behavior:
The key BASISINSTALLLOCATION should point to the right folder or the folder should be created on this location

Platform (if different from the browser): 
Windows 7 32 Bit
              
Browser: Mozilla/5.0 (Windows NT 6.1; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Comment 1 Stephan Bergmann 2012-02-21 05:53:10 UTC
This is fallout from the basis/brand re-merge in LO 3.5.  Not sure this Windows registry key is intended for external use at all.  So we can either remove it or make it point to the same dir as INSTALLLOCATION.

(Note that setup_native/source/win32/customactions/reg64/reg64.cxx also mentions BASISINSTALLLOCATION.)
Comment 2 Andras Timar 2012-02-24 02:47:25 UTC
For 3.5.x I prefer not to remove it. Let it point to INSTALLLOCATION.
Comment 3 Not Assigned 2012-02-24 02:48:54 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=06dd0fda38f07a74ba8469542ed4afe93b47ee9c

fdo#46377 BASISINSTALLLOCATION = INSTALLLOCATION
Comment 4 Not Assigned 2012-02-24 04:37:48 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=05e415f8e98107ef4267939d93b641a35d58cce2&g=libreoffice-3-5

fdo#46377 BASISINSTALLLOCATION = INSTALLLOCATION


It will be available in LibreOffice 3.5.2.
Comment 5 Not Assigned 2012-02-24 06:26:57 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=274407ccd9eaf7bf759650e259470fa44999e3bc&g=libreoffice-3-5-1

fdo#46377 BASISINSTALLLOCATION = INSTALLLOCATION


It will be available already in LibreOffice 3.5.1.
Comment 6 Rainer Bielefeld Retired 2012-04-05 08:06:47 UTC
I added Fix submitter as assignee because this will ease queries and bug tracking.