Bug 46400 - : Wrong generated HTML: Hyperlink on image contaminates the following text
Summary: : Wrong generated HTML: Hyperlink on image contaminates the following text
Status: RESOLVED DUPLICATE of bug 58286
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: BSA
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2012-02-21 08:21 UTC by contact
Modified: 2015-12-17 06:51 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
This file was generated as described in the bug report and illustrates the missing </A> tag following the hyperlinked image and before the "xxx" text. (737 bytes, text/html)
2012-09-23 16:49 UTC, brent
Details
new test with 3.6 branch (104.35 KB, application/vnd.oasis.opendocument.text)
2012-10-28 22:00 UTC, Julien Nabet
Details
result of the test with 3.6 branch (127.84 KB, text/html)
2012-10-29 07:43 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description contact 2012-02-21 08:21:04 UTC
Problem description: 

Steps to reproduce:
1. Using LibreOffice Writer
2. Insert an image with an anchor as character
3. Define a Hyperlink on it
5. Type some text after that image
4. Generate an HTML file using export to HTML
5. Open the HTML

Current behavior:
- The hyperlink is also applied to the text following the image.

Expected behavior:
- The hyperlink is only defined on the image not on the following text.

That didn't appear on 3.4.x

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Comment 1 sasha.libreoffice 2012-05-23 02:45:20 UTC
Thanks for bugreport
Please, attach LibreOffice document, produced in step 5 (for test purposes)
Comment 2 brent 2012-09-23 16:49:31 UTC
Created attachment 67584 [details]
This file was generated as described in the bug report and illustrates the missing </A> tag following the hyperlinked image and before the "xxx" text.
Comment 3 sasha.libreoffice 2012-09-24 05:49:31 UTC
Thanks for additional testing
Reproduced in 3.6.1 on Fedora 64 bit (Using File->Save as)
But in 3.3.4 not reproducible, therefore regression
Comment 4 Julien Nabet 2012-10-28 22:00:07 UTC
Created attachment 69202 [details]
new test with 3.6 branch

On pc Debian x86-64 with 3.6 branch updated today, I don't reproduce the bug. (or perhaps missed something).
http://cgit.freedesktop.org/libreoffice/core/log/?qt=grep&q=hyperlink shows some fixes about hyperlinks so it could be ok now.

Could anybody confirm?
Comment 5 sasha.libreoffice 2012-10-29 06:31:30 UTC
reproduced in 3.6.2 (installed from rpm from libreoffice.org) on RFR 17 64 bit
Steps to reporduce:
0. Open second attachment in Writer
1. File->Save as, select HTML as file type
2. Open resulting html with Web-browser
Expected: text after picture seen as text
Actually: text becomes link to google.fr
Comment 6 Julien Nabet 2012-10-29 07:43:30 UTC
Created attachment 69210 [details]
result of the test with 3.6 branch

Sasha: perhaps the fix is only on 3.6 branch so it'll be only on 3.6.4 but would you mind trying prerelease 3.6.3?
Comment 7 sasha.libreoffice 2012-10-29 09:08:50 UTC
> but would you mind trying prerelease 3.6.3?
No, sorry. Will wait until release 3.6.3. I hope it will appear in next week.
Comment 8 Julien Nabet 2012-10-29 22:34:04 UTC
(In reply to comment #7)
> > but would you mind trying prerelease 3.6.3?
> No, sorry. Will wait until release 3.6.3. I hope it will appear in next week.
No pb :-)
BTW, I tested on Vista with LO 3.6.2.2, I don't reproduce this, strange...
Comment 9 beimaginativeegroup 2013-05-29 15:41:16 UTC
I am changing component to Writer. This does not have to do with LibreOffice's online presence itself.
Comment 10 Miklos Vajna 2013-08-06 11:59:28 UTC
This is no longer an issue as of a923084f872b8ce13f6213827fe5b1c711e6b15f.
Comment 11 Miklos Vajna 2013-08-06 12:00:08 UTC

*** This bug has been marked as a duplicate of bug 58286 ***
Comment 12 Robinson Tryon (qubit) 2015-12-17 06:51:38 UTC
Migrating Whiteboard tags to Keywords: (bibisectrequest)
[NinjaEdit]