Bug Hunting Session
Bug 46409 - : Installer fails due to lack of admin permission
Summary: : Installer fails due to lack of admin permission
Status: RESOLVED DUPLICATE of bug 36677
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 RC1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-21 10:48 UTC by jbuckmaster
Modified: 2012-02-22 09:20 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jbuckmaster 2012-02-21 10:48:34 UTC
Problem description: 
Installer gives error of stating that the user needs to close LibreOffice .4 before continuing, even if LibreOffice is not running.

Steps to reproduce:
1. Have a previous version of LibreOffice installed on Windows 7 x64 (probably happens on x86 as well)

2. Attempt to run .msi installer.

Current behavior:
Installer exits with incorrect message.

Expected behavior:
Actually install the application. Ask for permission to run if it is not running as admin.

NOTE:
It appears as if the inability to uninstall the previous version is caught as the previous version is active, rather than the program not having permission. As a msi file, you cannot right click and run as admin. Application can be installed if you run cmd.exe as admin and then run the installer from the command line.  The installer should be able to ask for permission to run as admin and thus avoid this problem.



Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.56 Safari/535.11
Comment 1 Urmas 2012-02-22 09:20:01 UTC

*** This bug has been marked as a duplicate of bug 36677 ***