Download it now!
Bug 46411 - i18n: add locale data for Pitjantjatjara (pjt)
Summary: i18n: add locale data for Pitjantjatjara (pjt)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Eike Rathke
URL:
Whiteboard: target:3.6.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-21 11:08 UTC by Kevin Scannell
Modified: 2012-02-28 07:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
pjt locale file (13.05 KB, text/xml)
2012-02-21 11:08 UTC, Kevin Scannell
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Scannell 2012-02-21 11:08:44 UTC
Created attachment 57411 [details]
pjt locale file

I am submitting a locale file on behalf of Peter Ruwoldt and Paul Eckert.
Comment 1 Eike Rathke 2012-02-21 14:42:54 UTC
Thanks.

Test compiling that gave

Warning: QuotationStart may be wrong: U+201C “
Warning: QuotationEnd may be wrong: U+201D ”
Warning: DoubleQuotationStart may be wrong: U+2018 ‘
Warning: DoubleQuotationEnd may be wrong: U+2019 ’

This just looks like single and double quotation marks are swapped and can be
easily fixed. But this

Warning: FormatCode formatindex="12" for currency uses parentheses for negative amounts, which probably is not correct for locales not based on en_US.
Warning: FormatCode formatindex="13" for currency uses parentheses for negative amounts, which probably is not correct for locales not based on en_US.
Warning: FormatCode formatindex="14" for currency uses parentheses for negative amounts, which probably is not correct for locales not based on en_US.
Warning: FormatCode formatindex="15" for currency uses parentheses for negative amounts, which probably is not correct for locales not based on en_US.
Warning: FormatCode formatindex="17" for currency uses parentheses for negative amounts, which probably is not correct for locales not based on en_US.

is because of the format codes

[CURRENCY]#,##0.00;([CURRENCY]#,##0.00)

and the negative format could be any of leading or trailing negative sign, or
maybe yet something different. I assume it should be the same as in the en-AU
locale

[CURRENCY]#,##0.00;-[CURRENCY]#,##0.00

Correct?
Comment 2 Kevin Scannell 2012-02-21 15:11:31 UTC
Hi Eike, thanks.  Got a reply from Peter on the issues you raised: 
"Quotes reversed were accidental
Currency formatting en-AU is correct"

Will you edit the file or shall I upload a new version as an attachment?
Comment 3 Eike Rathke 2012-02-21 15:33:07 UTC
This file is quite useless.. apparently there's nothing localized except trueWord and falseWord, other reserved words and day and month names are all English. We could default everything to en-AU instead as well.
Comment 4 Kevin Scannell 2012-02-22 07:00:12 UTC
I've asked Peter to create an account and give us more details. I suspect the issue is that there simply aren't words for the western months in the language.

Even if so, the locale file is far from useless as it would be needed to make the spell checker they're working on usable.
Comment 5 Eike Rathke 2012-02-22 07:09:43 UTC
Might be that there are no translated names. Would be good to clarify.

Note though that for character attribution and thus spell checking a locale data file is not needed, that only needs an entry in the language list and some mappings, see also https://wiki.documentfoundation.org/LibreOffice_Localization_Guide/Adding_a_New_Language_or_Locale

No need to file a separate issue for that, I'll just add the necessary entries and we can sort out the locale data details independently.
Comment 6 Not Assigned 2012-02-23 03:30:17 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=082b2bca9f82e760c0092bde3d46242c446ebdb8

fdo#46411 added [pjt-AU] Pitjantjatjara to language list
Comment 7 Kevin Scannell 2012-02-23 07:46:01 UTC
Thanks Eike, this is great!  And glad to know it's that much easier to add languages now - I may submit a patch occasionally as we release new spell checkers.
Comment 8 Peter Ruwoldt 2012-02-25 01:09:26 UTC
This is true Kevin.  The language is an indigenous group from the centre of Australia. It is basically a stone age language.  People here know people who remembered and have passed on their stories of first white fella contact. Consequently there are things like the idea of months, currency, days of the week that did not exist in their language and culture.  For these things they have adopted the english.  (In reply to comment #4)
> I've asked Peter to create an account and give us more details. I suspect the
> issue is that there simply aren't words for the western months in the language.
> 
> Even if so, the locale file is far from useless as it would be needed to make
> the spell checker they're working on usable.
Comment 9 Not Assigned 2012-02-28 07:15:02 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=20c25d497a0d35a68a7dea9a0d7bc5b667a40ad4

fdo#46411 added [pjt-AU] Pitjantjatjara locale data
Comment 10 Eike Rathke 2012-02-28 07:26:01 UTC
To not duplicate data I made LC_CALENDAR, LC_NumberingLevel and LC_OutLineNumberingLevel reference en_AU locale data.

While at it I noticed that most differences in LC_FORMAT are due to the LongDateDaySeparator that in pjt_AU is ", " and in en_AU only " ", plus some other minor differences. Someone in the know could check en_AU usage of long date separators in FormatElement codes. Maybe they should be changed, and then pjt_AU could inherit also the entire LC_FORMAT element.