Bug Hunting Session
Bug 46428 - Broken import of Excel file
Summary: Broken import of Excel file
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-21 23:43 UTC by Tim Mensch
Modified: 2013-11-28 22:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The corrupt .ods generated by loading an xslx file. (11.73 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-02-21 23:43 UTC, Tim Mensch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Mensch 2012-02-21 23:43:47 UTC
Created attachment 57436 [details]
The corrupt .ods generated by loading an xslx file.

I tried to import an xslx file into LibreOffice, and it ended up broken: The first column of data overlap the column of row #s, and their drawing is messed up (whichever one updates last gets drawn).

I saved it out as ods hoping that would fix it, but no luck.

I tried importing the original xslx file back into LibreOffice today, and it actually imported correctly. I couldn't swear I was running 3.5.0 when the import failed the first time, but I was somewhat sure that I grabbed 3.5 on the day it was released, and that I had imported the file using the new version when I received it on the 17th. 

In fact I recall being disappointed that the brand new version was failing on the second file I tried. So I can't explain why it works now and didn't work then, unless the first xslx file I imported left Calc in a bad state.

I'm attaching the corrupted .ods file with the data removed. It still loads in a broken manner as described above, even in 3.5.0.

So for me, I don't need any help at the moment, since the file loaded. But I thought you might want to see a corrupt .ods file that stays corrupt even after you load it and resave it.
Comment 1 ign_christian 2013-06-24 08:53:45 UTC
Please attach that original xlsx file if not private, then mark this bug UNCONFIRMED.

Have you tried latest stable release & resetting user profile?
Comment 2 Urmas 2013-06-24 14:53:00 UTC
It's a dup.
Comment 3 Tim Mensch 2013-06-24 17:06:40 UTC
Sorry, this was over a year ago. I've since paid the Microsoft tax and purchased a real version of Office, so I am no longer using LibreOffice.

What I did attach was the broken file; it might be useful to have Calc verify the data as it reads it to ensure that Calc itself doesn't get into a bad state.
Comment 4 Joel Madero 2013-06-25 22:42:18 UTC
Unfortunately without the original document there's very little we can do.

Closing as INVALID - Urmas if you happen to know what it's a dupe of feel free to mark it as such.