Bug 46441 - FILESAVE: frame and it's content lost after saving to .doc of specific .odt
Summary: FILESAVE: frame and it's content lost after saving to .doc of specific .odt
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: low normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:doc
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2012-02-22 04:41 UTC by Kobus
Modified: 2021-12-15 04:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The document (367.25 KB, application/vnd.oasis.opendocument.text)
2012-02-23 06:57 UTC, Kobus
Details
stripped version of test document (14.33 KB, application/vnd.oasis.opendocument.text)
2015-07-19 09:04 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kobus 2012-02-22 04:41:32 UTC
Problem description: 
When I save the document to Microsoft Word 97/2000/XP some of the text on the first page is not in the saved (.doc) version. My wife experienced this on Ubuntu 11.10 with LibreOffice 3.4.4 and I tried it on Ubuntu 11.04 with LibreOffice 3.3.4 with the same effect.

Steps to reproduce:
1. Load the attached ODF document in writer.
2. Notice the text to the right of the photograph on page 1.
3. Save the documents in Word 97/2000/XP format.
4. Open the .doc document. 

Alternative steps:
1. Save the document in .doc format.
2. Open the document and edit the text to the right of the image on page 1.
3. Save the document (in .doc) format and close it.
4. Open the document.

Current behavior:
The text on page 1 to the right of the photograph is gone. I've had attempts where this didn't happen, but then the next attempt the text was lost.

Expected behavior:
The content of the document should be preserved.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2
Comment 1 Urmas 2012-02-22 09:32:04 UTC Comment hidden (obsolete)
Comment 2 Kobus 2012-02-23 06:57:57 UTC
Created attachment 57526 [details]
The document

I was sure I attached it...
Comment 3 s-joyemusequna 2012-02-25 00:44:47 UTC
Tested On Windows XP / Vista 64:

the same error occurs with LibO 3.3.4, 3.4.5, and 3.5.0
Comment 4 retired 2013-09-22 09:09:57 UTC
Still valid for latest LO 4.2 master build 2013-09-16.

When saving test document as .doc then opening with Word 2010, the text on the right side of the image on page 1 is gone.
Comment 5 tommy27 2014-06-23 11:25:26 UTC
same issue with 4.2.4.2 under Win7x64
Comment 6 QA Administrators 2015-07-18 17:43:08 UTC Comment hidden (obsolete)
Comment 7 tommy27 2015-07-19 09:04:00 UTC
Created attachment 117328 [details]
stripped version of test document

still reproducible under WIN8.1x64 using LibO 4.4.5.1 and 5.1.0.0.alpha1+ (x64)
Build ID: 5a61d7f049a81d6e747d9d097f364ae45f58697b
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-16_01:06:26
Locale: en-US (it_IT)

I'm uploading a stripped version of the original test document.
text is lost after saving it as .DOC and reloading it

adding Writer developer to CC list.
Comment 8 tommy27 2015-07-19 09:11:23 UTC
interestingly deleting the "P" in the top left corner in the .ODT file using backspace deletes also the text below
Comment 9 QA Administrators 2016-09-20 10:18:22 UTC Comment hidden (obsolete)
Comment 10 Telesto 2016-12-12 19:33:07 UTC
Still repro with:
Version: 5.4.0.0.alpha0+
Build ID: 84f2ff67a7e404febf710b1dc7f66d06745c503f
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-09_23:20:01
Locale: nl-NL (nl_NL); Calc: CL
Comment 11 QA Administrators 2017-12-13 09:30:26 UTC Comment hidden (obsolete)
Comment 12 QA Administrators 2019-12-14 03:41:11 UTC Comment hidden (obsolete)
Comment 13 Timur 2019-12-15 18:18:42 UTC
Repro Lo 6.5+ frame lost wheb saving to .doc. (saving to .docx moves frame).
By opening in MSO verified it's filesave issue. 
This is some special case, beacase frame and floating frame are exported.
No info how .odt was created, it wouldn't surprise that content was copied.
Low priority.
Comment 14 QA Administrators 2021-12-15 04:41:29 UTC
Dear Kobus,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://web.libera.chat/?settings=#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug