Bug Hunting Session
Bug 46520 (PPT4-pre97) - [FILEOPEN] "Incorrect file version" when opening a PPT v 4.0 file--pre 97-2003 binary format-- (error message need to be improved)
Summary: [FILEOPEN] "Incorrect file version" when opening a PPT v 4.0 file--pre 97-200...
Status: RESOLVED WORKSFORME
Alias: PPT4-pre97
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.1 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL: http://theory.lcs.mit.edu/~rivest/sds...
Whiteboard:
Keywords:
: 83861 87068 (view as bug list)
Depends on:
Blocks: Error-Messages MSO-Formats
  Show dependency treegraph
 
Reported: 2012-02-23 06:08 UTC by Cesar Eduardo Barros
Modified: 2019-10-09 13:21 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cesar Eduardo Barros 2012-02-23 06:08:12 UTC
When attempting to open the file http://theory.lcs.mit.edu/~rivest/sdsi20-maryland.ppt, found at http://groups.csail.mit.edu/cis/sdsi.html, LibreOffice fails to open the file and shows a small ugly dialog saying only the following (in pt-BR):

"LibreOffice 3.4
Versão Incompatível.
Versão de arquivo incorreta."

I checked the translations file, and the corresponding English message seems to be:

Version Incompatibility.
Incorrect file version.

(ERRCODE_CLASS_VERSION/ERRCODE_IO_WRONGVERSION according to the comments in the .po file.)

The same happens to some other PPT files found at that page (I tested a couple of them).

I am using the Fedora 16 packages, version 3.4.5.2-5.fc16.x86_64.
Comment 1 dajbuzi 2012-04-02 01:40:09 UTC
Hi,

  I've encountered the same problem in debian wheezy. My LibreOffice version is: LibreOffice 3.4  340m1(Build:602)
Comment 2 Abhishek Singh 2012-05-07 21:31:22 UTC
I've encountered the same problem when I saved my file into a ppt format and changed the file name. When I tried to reopen the file, it didn't open at all and threw the :

Version Incompatibility.
Incorrect file version.

I'm using LibreOffice 3.4.5 (from a Fedora repository), more specifically 3.4.5.2-13.fc16.x86_64.

I hereby confirm this bug.
Comment 3 sasha.libreoffice 2012-05-23 07:42:11 UTC
Thanks for bugreport
msOffice 2007 tells that file is incorrect. Therefore it is not a bug. Just corrupted file.
Comment 4 Cesar Eduardo Barros 2012-05-23 15:59:08 UTC
(In reply to comment #3)
> Thanks for bugreport
> msOffice 2007 tells that file is incorrect. Therefore it is not a bug. Just
> corrupted file.

It is also possible that MS Office 2007 can no longer open PowerPoint 4.0 files. These files are from 1996-1997. Did you try with an older version of MS Office? (I do not have any version of MS Office here to test.)

The "file" command shows the following for the sdsi20-maryland.ppt file:

sdsi20-maryland.ppt: Composite Document File V2 Document, Little Endian, Os: Windows, Version 4.0, Code page: 1252, Title: On Public-Key Infrastructures, Author: Ronald L. Rivest, Template: c:\powerpnt\template\clrovrhd\sidebarc.ppt, Last Saved By: Ronald L. Rivest, Revision Number: 123, Name of Creating Application: Microsoft PowerPoint 4.0, Total Editing Time: -5340335d+-18:-21:-51, Last Printed: Thu Apr 10 01:32:24 1997, Create Time/Date: Tue Aug 13 18:55:52 1996, Last Saved Time/Date: Thu Apr 10 12:28:14 1997, Number of Pages: 36, Number of Words: 2321

Even if LibreOffice cannot open these old files, it should at least have a better error message explaining the problem.
Comment 5 A (Andy) 2013-04-27 09:28:13 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)

I also tried it with MSO 2007 and as Sasha wrote, I can also confirm that MSO 2007 can not open it, too.

I agree that LO should not need to support all old, ancient file types, but it would be good if LO could at least open it and save in a new format (or automatically convert it to a new version), even is MSO can not do this (would be another advantage over MSO).
Comment 6 Frédéric Grosshans 2014-01-26 17:30:07 UTC
I have similar problem, and I’ll try soon to open sdsi20-maryland.ppt in an old version of MSO to confirm the file is valid.

Inbetween, under linux, I’ve managed to extract some information using ripOLE v0.2.1 (http://www.pldaniels.com/ripole/):

$ ripole -i sdsi20-maryland.ppt --save-unknown-streams -v
Decoding filename=ole-stream.369
Decoding filename=ole-stream.353
Decoding filename=ole-stream.0
Decoding filename=ole-stream.361
Decoding filename=ole-stream.345
olestream-unwrap.c:183:OLEUNWRAP_save_stream:ERROR: Unable to open ./ for writing (Is a directory)

The file ole-stream.369, in particular, contains 337 lines of valid WIN-1252 text, which probably is the text on the slides. This confirm that everything is not corrupted in this file.
Comment 7 Basti 2014-02-04 15:20:21 UTC
I have the same problem with LO 4.1.4-2.
I can open the file with MSO 2010 without any problems.
So I think save a ppt-file in MSO 2010 != save this file format in older versions.

p.s. With MSO 2007 there is the same error with 
"Version Incompatibility.
Incorrect file version."
Comment 8 V Stuart Foote 2014-12-07 17:52:32 UTC
*** Bug 87068 has been marked as a duplicate of this bug. ***
Comment 9 V Stuart Foote 2014-12-07 18:02:22 UTC
Legacy PowerPoint 4.0 (pre-1997) have no import filter support in LibreOffice.

Should there be? Probably not, but there are some old presentations still out there that folks may need to convert. Per comment 7, looks lik MS added it back in PowerPoint 2010, verified support is missing in the 2007 release. Will check 2013.

But, can't see this as too much our responsibility to support.
Comment 10 Maxim Monastirsky 2014-12-07 20:12:27 UTC
(In reply to V Stuart Foote from comment #9)
> Legacy PowerPoint 4.0 (pre-1997) have no import filter support in
> LibreOffice.
> 
> Should there be? Probably not,
Why not? If we support ancient Mac formats, and also Excel for Windows starting from version 2.0 and WinWord from ver. 1.0, I see no reason why we shouldn't support PowerPoint 4.0.

BTW the file from Bug 87068 is a bit different that the files of this bug. The document stream seems to be named "PP40" instead of "PowerPoint Document", so the type detection code isn't detecting it as a PP file at all, and it passed to the Writer ascii filter instead.
Comment 11 Maxim Monastirsky 2014-12-07 20:16:52 UTC
*** Bug 83861 has been marked as a duplicate of this bug. ***
Comment 12 QA Administrators 2015-12-20 16:18:32 UTC Comment hidden (obsolete)
Comment 13 Cesar Eduardo Barros 2015-12-20 18:16:41 UTC
Tested again with libreoffice-5.0.3.2-12.fc23.x86_64, still the same error message.
Comment 14 Frédéric Grosshans 2016-11-19 12:31:19 UTC
The bug is still active in LibreOffice 5.2.2.

Version: 5.2.2.2
Build ID: 1:5.2.2-0ubuntu2
Threads CPU : 4; Version de l'OS :Linux 4.8;
Comment 15 Xisco Faulí 2017-07-13 10:05:32 UTC
Setting Assignee back to default. Please assign it back to yourself if you're still working on this issue
Comment 16 osnola 2017-08-22 14:57:51 UTC
Hello,
normally LibreOffice 5.4 can now "open" these old ppt files(*), so this dialog must not appear again. 

(*) ie. I had added a basic filter to read these old PowerPoint's files in libmwaw : a filter which may be able to retrieve the main content of these files (even if many problems remain to be solved).
Comment 17 Antonio Vinicius Menezes Medeiros 2018-01-22 20:31:34 UTC
I can reproduce that bug using

- LibreOffice 4.1.5.3 on Windows 7 64-bit with SP1
- LibreOffice 5.3.5.2 on openSUSE 42.3 x64

But I was able to open sdsi20-maryland.ppt using LibreOffice 5.4.4 Portable MultilingualStandard I downloaded from:

https://www.libreoffice.org/download/portable-versions/
Comment 18 QA Administrators 2019-10-08 02:28:51 UTC Comment hidden (obsolete)
Comment 19 Frédéric Grosshans 2019-10-09 12:31:52 UTC
It now works for me. Thanks for everyone involved. (I don’t know if I’m allowed to change the status to WORKSFORME, since I’m   not the original reporter)

Version: 6.2.7.1
Build ID: 1:6.2.7-0ubuntu0.19.04.1
Threads CPU : 4; OS : Linux 5.0; UI Render : par défaut; VCL: gtk3; 
Locale : fr-FR (fr_FR.utf8); Langue IHM : fr-FR
Calc: threaded
Comment 20 raal 2019-10-09 13:21:06 UTC
I can open the file with Version: 6.4.0.0.alpha0+ (x64)
Build ID: 25ca657f8d0f1febaf0d5984bc862f3072ad197b
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 

Closing the bug