Bug Hunting Session
Bug 46549 - Libreoffice Grammar Check returns, "bad article," incorrectly
Summary: Libreoffice Grammar Check returns, "bad article," incorrectly
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: low minor
Assignee: László Németh
URL:
Whiteboard: target:3.6.2 target:3.5.7
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-23 18:07 UTC by jacobwwood
Modified: 2012-08-27 06:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jacobwwood 2012-02-23 18:07:10 UTC
In the following sentence...

The Catechism of the Catholic Church defines virtue as “an habitual and firm disposition to do the good… he pursues the good and chooses it in concrete actions (CCC 1804).”

...Libreoffice Grammar Check (English USA) returned "bad article" for "an habitual" and suggested "a habitual." However, English usage allows "an" before a word beginning with "h", even though the "h" be hard, as in "an historical occasion".
Comment 1 Roman Eisele 2012-05-24 02:55:36 UTC
REPRODUCIBLE with LibreOffice 3.5.4.1 (Build-ID: 7306755-f4f605c-738527d-1cf4bc1-9930dc8) on MacOS X 10.6.8.

Therefore changed Status to NEW and Platform to All (not Linux only).

NB: I can reproduce the problem only with "... an habitual ...", not with "... an historian ...": the 2nd example mentioned is not marked as wrong. So "historian" seems to be included within some exceptions list, but "habitual" not.

This is a Grammer checker issue, therefore changed the Component field accordingly to "Linguistic".
Comment 2 László Németh 2012-08-23 14:33:06 UTC
Thanks for the bug report. It will be fixed soon.
Comment 3 Not Assigned 2012-08-27 05:58:50 UTC
Laszlo Nemeth committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=ac9de2e7157d7c1c30df5d6b91e1281ca182bc0d&g=libreoffice-3-6

fdo#46549 indefinite article "an" is allowed before word "habitual"


It will be available in LibreOffice 3.6.2.
Comment 4 Not Assigned 2012-08-27 06:05:16 UTC
Laszlo Nemeth committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=4a225496039498a65233bd841900907401e0561c&g=libreoffice-3-5

fdo#46549 indefinite article "an" is allowed before word "habitual"


It will be available in LibreOffice 3.5.7.