Bug 46550 - FORMATTING Styles Editing need better defaults and better previews of settings.
Summary: FORMATTING Styles Editing need better defaults and better previews of settings.
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: Live-Preview 47295 83362 90497 102002
Blocks: Writer-Styles Writer-UX
  Show dependency treegraph
 
Reported: 2012-02-23 18:25 UTC by Jon Grossart
Modified: 2018-09-13 09:02 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Grossart 2012-02-23 18:25:41 UTC
So, I've been working on ditching MS Office and moving completely over to LibO. As a professional, I take a lot of notes in my continuing ed classes, which of course requires a lot of repetitive formatting.

MS Office makes this somewhat of a breeze to make "pretty" documents.  It has "Quick Styles" which let you easily change the basic look of the document (set styling for title/headers).

In LibO, this is a giant pain. It comes with no built options (fine as a default), but has no ability to have a set of "style sets". I can import them from another doc or template, but then I don't have the fine grain to really just select the parts I want other than "text", "frame", "page", etc.

Also, editting the styles is also over complex, i.e., lacking a UX. To even get to the styling menu, I have to pull the F11 styling window, then actually find the style I want.  Then right click, then edit it in a separate pop-up window with multiple tabs. Rinse and repeat.

One thing LibO does better is to be able to have a list style created as a style, and then be able to apply the same one everywhere.  MS Office only has a "continue previous list" option if you want something other than the built in choices (from what I've seen).

Enhancement Request:
1a) add something like Quick Styles for basic formatting styles 
 or
1b) add some what to actually see what you're going to be pulling in from an import of styles or show the conflicts in stead of just "no overwrite" or "overwrite"

2) add a styles UI
i) add a preview of the style as you're creating it so you can see the spacing, color, margins, etc. as you're working on it. You can do this with font already, but not with the other parts. It could have a single preview all the options (using the page margin graphics from a normal document so you could see the edges of the "box" you're creating).
ii) could integrate the list/bullet stuff into this styles UI, which has it's own mini-preview, but under a different window.

3) change name of some of default styles
As I was looking through the bugs/discussion of styles looking for info, someone who seemed to know what they were talking about said to never alter "default" other than for font family and size because everything else cascades off of then; he also said to use "text body" for all of your actual text. However, when you start a new document, default comes up as the first style being used. If I'm just typing away, and not using headers, then I never see "Text Body" pop up as the current default style. Plus, if you go back and do headers later, it doesn't fix the text after it to be "text body".

Again, coming from MS Office, "Default" is used there as only default from before Office 2007 for single spaced, no space between paragraphs/carriage returns. In LibO, default is the base style. It might be helpful to change it "Base", or "Parent" and change the default style when you open a document to be "Text Body". And it might be helpful to limit options or least warn when editing "Default" about the huge effects it can have.
Comment 1 Joel Madero 2012-08-07 15:19:57 UTC
I just played around with MS Word a bit and I agree, their system seems to be a bit more of a breeze to make things pretty. I'm going to mark this as NEW and leave as a HIGH priority. I'll let whoever gets a chance to pick this up decide on how to implement. They may have questions but this is a bigger request so it most likely will be awhile before someone gets a chance. 

I'm going to CC two of the developers which are more active in the Writer component. Maybe they'll have further input. 

Cédric and Michael, what do you think?
Comment 2 Cédric Bosdonnat 2014-01-20 08:57:51 UTC
Restricted my LibreOffice hacking area
Comment 3 Timur 2017-06-02 12:44:51 UTC
This is rather old report. Please compare with current LO versions, like 5.3 or preferably with master that is now 5.5+. 

Please comment whether Sidebar-Properties with New Style and Update Style is what's expected. 
If you prepare desired text formatting, click on "New Style" there creates new style, similar to "Save selection as new quick style".

"default comes up as the first style being used" is another Bug 47295 so 3) is not relevant here. Anyway, bug report should not deal with multiple issues. 

You may get http://tdf.io/siguiexe to easily get and run "parallel" LO in Windows (extract without installation) in order to test newer Lo versions.
Comment 4 Thomas Lendo 2017-06-05 15:29:46 UTC
My opinion is that the issues Jon mentioned are all more than valid. But a bug should handle one issue. This bug can't be handled by developers or the UX team as it is. Maybe as a META bug.

Timur links to other bugs already filed. Another one would be Bug 90497 - "Implementing document themes".

Styles are better visible for users when Bug 106781- "Addition of a style-focused formatting toolbar is fully implemented". But styles are a controversial discussed topic and Ben isn't using styles at all, so it's unlikely that there will be efforts or GSoC projects to make LO better in giving end users an easy way to work with.

Preview of styles was implemented in the Sidebar a few versions ago.

@Jon: I would request to report separate issues with proposals for solution or at least to show what's wrong in today's workflow. That would ease further discussions and improvements.
Comment 5 Jon Grossart 2017-06-05 19:10:39 UTC
@Timur, while the sidebar does help with a lot of formatting, it doesn't relate the issues I've brought up. These are more about the overall process of editing the styles of a whole document, or even more correctly, a whole group of related documents.

@Thomas, this could probably be split into several issues. However, I already put it as an enhancement, which should cover that, not as a bug. And quite frankly, since this has sat for over 5 years without ever having any real comment or change in the issue, I don't think splitting it up would do anything either, as I've already proposed solutions in the original description.

I'd be more than happy to converse with anyone on the UX/template team about issues though, and how to best make progress.
Comment 6 Thomas Lendo 2017-06-08 22:40:59 UTC
(In reply to Jon Grossart from comment #5)
> @Thomas, this could probably be split into several issues. However, I
> already put it as an enhancement, which should cover that, not as a bug.
In reality there is no difference in being a problem or an enhancement, both is a "bug" in Bugzilla. It's only a kind of sorting for developers and the QA team.

> quite frankly, since this has sat for over 5 years without ever having any
> real comment or change in the issue, I don't think splitting it up would do
> anything either, as I've already proposed solutions in the original
> description.
Most bugs are waiting several years for fixing. You need hope.
What I mean with splitting: You have to think like a developer/software engineer when creating a bug. Developers want a straight, easy and focused report with that they can work. A mishmash of ideas or a vague report is not helpful or "appealing" for them.

> I'd be more than happy to converse with anyone on the UX/template team about
> issues though, and how to best make progress.
https://wiki.documentfoundation.org/Design
There you can find some material and ways to get in contact through miscellaneous channels. You're always welcome!
Comment 7 Timur 2017-10-16 15:42:08 UTC
> Enhancement Request:
> 1a) add something like Quick Styles for basic formatting styles 
I already noted Sidebar-Properties with "New Style" and "Update Style" buttons. And Thomas referenced Bug 90497. 

>  or
> 1b) add some what to actually see what you're going to be pulling in from an
> import of styles or show the conflicts in stead of just "no overwrite" or
> "overwrite"
Not sure what this is, Bug 102002?

> 2) add a styles UI
Bug 83362 and Bug 

> 3) change name of some of default styles
Bug 37048 and Bug 47295.


That's all best tested in master LO version. Currently it's 6.0+.

This bug was put to New too soon. It's "negatively" titled: "Styles Editing is cumbersome and confusing" and it tackles different issues. 
Not only it's better to have "positively" titled bugs, but it helps focus on single issue that this this bug should be about. 
So if not closed because it's already somewhere in Bug 107326 or in bugs referenced here, this one should be renamed. Until then, I set to Needinfo.
Comment 8 QA Administrators 2018-05-02 15:47:47 UTC Comment hidden (obsolete)
Comment 9 Jon Grossart 2018-05-09 06:25:37 UTC
I would point out that all but one of these bugs you point out were filed literally years after my original report.

(In reply to Timur from comment #7)
> > Enhancement Request:
> > 1a) add something like Quick Styles for basic formatting styles 
> I already noted Sidebar-Properties with "New Style" and "Update Style"
> buttons. And Thomas referenced Bug 90497. 

There have been many improvements with previewing styles, but nothing nearly along the lines of quick styles like MS Office (or document themes as described in 90497, which is the same as basic idea).

> >  or
> > 1b) add some what to actually see what you're going to be pulling in from an
> > import of styles or show the conflicts in stead of just "no overwrite" or
> > "overwrite"
> Not sure what this is, Bug 102002?
> 

This newer request does seem to cover what I was mentioning -- finer grained control of what's being pulled in, or least showing you what's actually being pulled in that different from the current document.

> > 2) add a styles UI
> Bug 83362 and Bug 
> 

2i is not covered entirely. They've added showing the styles preview in the pull down menu, but my original intent some sort of master style editor, so you could see how it show you how it would look in a real document. The current style preview still only really shows you font styling and not things like margins/spacing/etc. Bug 37048 would be the closest one here for that.

2ii would be the one that is part of 83362. However, my overall point with this is that there should be a better, more accurate preview for bullets and numbers. It's gotten WAY better since 2012, but it's still got room to improve.

> > 3) change name of some of default styles
> Bug 37048 and Bug 47295.

Bug 47295 is probably the closest match.

> 
> That's all best tested in master LO version. Currently it's 6.0+.
> 
> This bug was put to New too soon. It's "negatively" titled: "Styles Editing
> is cumbersome and confusing" and it tackles different issues. 
> Not only it's better to have "positively" titled bugs, but it helps focus on
> single issue that this this bug should be about. 
> So if not closed because it's already somewhere in Bug 107326 or in bugs
> referenced here, this one should be renamed. Until then, I set to Needinfo.

None of those bugs you mentioned are even part of 107326, when they clearly should be. I don't know who is supposed to edit those meta bugs.
Comment 10 Dieter Praas 2018-05-10 06:47:20 UTC
(In reply to Jon Grossart from comment #9)

> None of those bugs you mentioned are even part of 107326, when they clearly
> should be. I don't know who is supposed to edit those meta bugs.

You also can add bugs to a meta bug.
Comment 11 Heiko Tietze 2018-05-15 09:14:52 UTC
This ticket is a mess. The initial request consists of 5 topics- please file one per ticket otherwise it cannot get resolved. META means (at least to me) the actual issues are reported in other tickets- and this one is just the umbrella. Finally, NEW -> NEEDSINFO (c7) -> UNCONFIRMED (I set it back to NEW now) is confusing too. 

About the request you should focus on your problem like "I want to change the appearance of my document with one click because...". Thing is that I disagree with your take: In LibO, this is a giant pain. ... has no ability to have a set of "style sets". You can use templates, the styles sidebar has a better usability compared to the ribbon section in MSO, and (as an experimental feature) there are document themes. Request #2 is about the styles preview. We resolved a couple of tickets recently as WONTFIX because the full preview is not manageable (see bug 115507 with referenced tickets). And #3 is being discussed somewhere else.

LibreOffice has changed a lot since the ticket was created. You can use the menu, shortcuts, or a new styles toolbar for working with styles. That doesn't mean we should stop improving things, in particular regarding templates like in bug 50699.

Putting all together my suggestion is to close this ticket and continue with the other topics
Comment 12 Xisco Faulí 2018-05-30 09:10:42 UTC
I agree with Heiko.
On the one hand, it doesn't make sense to have the META here, removing...
On the other hand, @Jon, would you mind creating separated reports for each topic so we can close this one?
Thank you in advance!!!
Comment 13 Cor Nouws 2018-09-13 09:02:50 UTC
closing - @Jan, * : please follow advise in comment #11