Bug 46625 - UI: Allow embedded movies to start on mouse click instead of automatically
Summary: UI: Allow embedded movies to start on mouse click instead of automatically
Status: RESOLVED DUPLICATE of bug 34940
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-25 12:14 UTC by sander
Modified: 2013-05-12 03:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sander 2012-02-25 12:14:08 UTC
Movies that are embedded in impress presentations are started automatically when the slide appears on the screen.  It would be nice if alternatively one could also have the movie start only when it is clicked on.
Comment 1 sasha.libreoffice 2012-04-03 08:28:02 UTC
Thanks for bugreport
I can reproduce this only on 3.4.3 on Windows XP:
When I add video to slide, then select it, add effect "Play" in Custom Animation pane, select it ant choose "Start on click", then after press F5 video begins immediately, then after click begins again.

version 3.5.1 always hangs on Windows XP and 7. On Fedora 64 bit video and audio not works at all in all versions.

In comparison: in msPP 2003 when we use Insert->Sound and video->from file, program asks: Play automatically or by mouse click? After click on either, automatically creates several effects on pane "Custom animation". By changing them, we can adjust how video will be played.

PS: in OpenOffice before 3.3.1 situation with video was slightly better, but I have forgotten how exactly it was.
Comment 2 sander 2012-04-05 08:12:02 UTC
Thanks, I had never noticed that 'costum animation panel'.  I guess it does what I want (even though it's a bit overwhelming at first).  Nevertheless, my movies _always_ autostart right after pressing F5, even without the 'play' effect.
Comment 3 sander 2012-05-31 01:33:11 UTC
Ideally I would like a context menu for the movie object that allows to control the usual options such as autostart (yes/no), looping (yes/no), show controls (yes/no), and to control what is being shown when the movie is not playing (first frame, another image).
Comment 4 ign_christian 2013-05-12 03:11:35 UTC

*** This bug has been marked as a duplicate of bug 34940 ***