Download it now!
Bug 46633 - FILESAVE RTF exporter saves corrupted ANSI data
Summary: FILESAVE RTF exporter saves corrupted ANSI data
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTF
  Show dependency treegraph
 
Reported: 2012-02-25 18:39 UTC by Urmas
Modified: 2018-06-17 12:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample (2.34 KB, application/msword)
2012-04-01 00:46 UTC, Urmas
Details
screen copy in LO 3.5.3 rc0+ (14.82 KB, image/png)
2012-04-15 11:03 UTC, Jean-Baptiste Faure
Details
Screenshot of actual file content (842 bytes, image/png)
2012-04-16 06:01 UTC, Urmas
Details
Same in the doc format (9.00 KB, application/msword)
2014-02-03 07:52 UTC, Urmas
Details
DOC file saved as rtf (4.07 KB, application/rtf)
2018-02-19 19:57 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2012-02-25 18:39:25 UTC
When saving a document in multiple languages (=character sets) in RTF format, the file contains characters produced by cutting a character's Unicode value to a single byte, instead of correct value in codepage specified by font's character set.
Comment 1 Jean-Baptiste Faure 2012-03-21 22:40:42 UTC
Please could you attach an odt file which shows the problem when exported as RTF ?

Best regards. JBF
Comment 2 Urmas 2012-04-01 00:46:14 UTC
Created attachment 59327 [details]
Sample
Comment 3 Jean-Baptiste Faure 2012-04-01 03:37:05 UTC
Thank you, but if the problem is in the export from odt to rtf, the source file in odt format should be useful to compare source and rtf result.

Best regards. JBF
Comment 4 Jean-Baptiste Faure 2012-04-15 11:03:37 UTC
Created attachment 60022 [details]
screen copy in LO 3.5.3 rc0+

Here is what I see in LO 3.5.3 rc0+ (LibreOffice 3.5.3rc0+ Version ID : 51c8c95-a73d29c-6845e52-f269e46-31eca31). Is it correct ?

Best regards. JBF
Comment 5 Urmas 2012-04-16 06:01:39 UTC
Created attachment 60062 [details]
Screenshot of actual file content

And that what software which doesn't use Unicode sees.
Comment 6 Urmas 2013-05-16 15:04:57 UTC
The problem seems to be related to a garbage charset value of 1 that somehow is recorded for some fonts. The value of DEFAULT_CHARSET is used by CreateFont function only, it is invalid for anything else.
Comment 7 Julien Nabet 2013-06-23 12:12:34 UTC
Urmas: Do you still reproduce this with a newer version?
If yes, could you attach the original file (.doc(x), odt)?
Comment 8 QA Administrators 2014-02-02 02:06:43 UTC
Dear Bug Submitter,

Please read the entire message before proceeding.

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 9 Jean-Baptiste Faure 2014-02-02 07:37:58 UTC
It seems that reporter do not want to provide the original file even if this file could allow to check if the bug is still present in current version. The actual bugdoc being corrupted (as said in the bug description), it is not useful to test the bug reproduction, only to see its effect.

So closing as INVALID.
Please feel free to reopen if you are willing to provide the requested informations.

Best regards. JBF
Comment 10 Urmas 2014-02-03 07:52:44 UTC
Created attachment 93262 [details]
Same in the doc format

Of course the error is present in current version.
Comment 11 Joel Madero 2015-05-02 15:43:33 UTC Comment hidden (obsolete)
Comment 12 QA Administrators 2016-09-20 09:37:17 UTC Comment hidden (obsolete)
Comment 13 Xisco Faulí 2017-06-26 19:00:36 UTC
This bug was never confirmed by a third person.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 14 QA Administrators 2018-01-29 10:27:47 UTC Comment hidden (obsolete)
Comment 15 Xisco Faulí 2018-01-30 10:30:24 UTC
You can't confirm your own bugs. Moving it back to UNCONFIRMED until someone
else confirms it.
Comment 16 Buovjaga 2018-02-19 19:57:08 UTC
Created attachment 140002 [details]
DOC file saved as rtf

I saved attachment 93262 [details] as rtf. No idea how to determine if it's bad or not.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: c902cbc7dc5294ab721a9aef3a152aa243d00011
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on February 17th 2018
Comment 17 Jean-Baptiste Faure 2018-06-17 12:35:35 UTC
I do not see any difference between the text document in doc format (attachement 93262) and its RTF export done by LibreOffice 6.0.4.

So I close this bug report as WorksForMe. Please feel free to reopen if you disagree. In that case, please explain precisely how to see that RTF export is faulty.

Best regards. JBF