Download it now!
Bug 46641 - EDITING: When sorting complex lists, references are broken
Summary: EDITING: When sorting complex lists, references are broken
Status: RESOLVED DUPLICATE of bug 81309
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-26 04:29 UTC by Nicolas Degand
Modified: 2014-10-16 04:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
A spreadsheet affected by the issue (10.87 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-02-26 04:29 UTC, Nicolas Degand
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Degand 2012-02-26 04:29:23 UTC
Created attachment 57656 [details]
A spreadsheet affected by the issue

If you sort cells in one sheet, references to them in other sheets are broken.

I attach a spreadsheet affected

It has two sheets:

Sheet 1: A list of indivduals (labelled from A to Y - column A) scoring points in two legs (Column C and D). Results of these two legs are aggregated  in column B (labelled Total).

Sheet 2: A list of teams. The individuals are actually grouped in teams (labelled from Team 1 to Team 15 - column A). For example, Team 3 is the addition of the results of individuals C, M and U.

The issue arise when I sort the sheets. If I do that, I expect the groupings in the sheet 2 to be unaffected. However, they are.

If I sort the sheet "Individual" by column B (with labels) from highest to lowest, I would have expected the sheet "Team" to be updated accordingly. 

Among other changes, in sheet 1the individual Y goes from row 26 to row 3. I thus expected the formula of the cell Team.B16 to change from "Individual.B26" to "Individual.B3". However, it is not updated.

I did not find any way to enable such a behaviour.
Comment 1 Noel Grandin 2012-09-05 10:48:38 UTC
This is not a bug, this a "I can't do this".

Please take your request to one the user forums.
Comment 2 Jean-Baptiste Faure 2014-10-16 04:44:28 UTC
This problem has been solved in the next 4.4 version; see bug 81309 and bug 81633 (configuration option added).

Note: in the present case, the configuration option works as expected. Check the option "Update references when sorting range of cells" to get the desired behavior, otherwise the "Team" sheet does not follow the changes made by sorting the "Individual" sheet.

Set as duplicate of bug 81309 and update the importance to enhancement.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 81309 ***