Bug Hunting Session
Bug 46706 - remove Win2K from list of system-requirements
Summary: remove Win2K from list of system-requirements
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: x86 (IA32) Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard: target:4.1.0 target:4.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-27 19:42 UTC by mhonline
Modified: 2013-01-31 20:47 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
silent crash past "save as" of old document (28.17 KB, image/jpeg)
2012-02-29 19:41 UTC, mhonline
Details
crash when saving this file past repair (87.77 KB, image/jpeg)
2012-02-29 19:42 UTC, mhonline
Details
Save as is working for me (104.83 KB, image/jpeg)
2012-03-08 13:52 UTC, Cesare Leonardi
Details
I can change the paths in the option window (110.74 KB, image/jpeg)
2012-03-08 13:54 UTC, Cesare Leonardi
Details
file causes crash (15.54 KB, application/vnd.oasis.opendocument.text)
2012-03-08 20:24 UTC, mhonline
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mhonline 2012-02-27 19:42:06 UTC
title says it, since file-locking, file-recovery, ODF-version-transformation and (new in 3.5) template-handling is not working anymore due to mismatch in procedures of file-handling (compiler-mismatch?!), you need to remove the WIN2000 immidiatly from compatibility-list.

martin


P.S
pls put that issue on list of most annoying bugs.
Comment 1 Andras Timar 2012-02-29 04:29:54 UTC
Can you please be a bit more specific. What did you do, what did you expect and what did not work on Windows 2000. We do not break intentionally compatibility with Windows 2000. And we have been using the same compiler (VS2008) for ages.
Comment 2 mhonline 2012-02-29 19:40:42 UTC
for example:

the procedure of "save as ..." is not functioning
see attached captures

pic. one: 
- result of a silent crash after "save as" of old document
- the procedure to "strip" a template from an ODF always fails

pic.two: 
"save as" of that very document, unchanged, just closed past the repair-process.


this is not happening on Win XP and above
and this is - also on Win2K as I rember - not happening in the portableapps-version. so I am quite sure, you (still) mix different compiler-version and (new) relay on some .net-configurations/functions, that do not exist in Win2K.

Martin
Comment 3 mhonline 2012-02-29 19:41:28 UTC
Created attachment 57841 [details]
silent crash past "save as" of old document
Comment 4 mhonline 2012-02-29 19:42:08 UTC
Created attachment 57842 [details]
crash when saving this file past repair
Comment 5 mhonline 2012-02-29 21:53:16 UTC
mistake
the portable version is crashing as often as the msi-version

m.
Comment 6 Petr Mladek 2012-03-01 01:55:10 UTC
Do you see the problem only with this particular document or with any document?

If it happens only with a single document, could you please attach it?
Comment 7 mhonline 2012-03-04 19:26:10 UTC
problems seems to come with any document, that is "saved as ..."
- repair-task opens
- repair and save  ==> crash
- skip repair and closed/discard changes ==> crash

Working, when JAVA is disabled/removed, appeared again, when JRE (16U31) is reinstalled.

Doc is not available

m.
Comment 8 Petr Mladek 2012-03-06 05:48:57 UTC
Please, what JRE are you using? The code 16U31 does not say anything to me. Also google is helpless.
Comment 9 mhonline 2012-03-06 10:13:17 UTC
JRE 6 Update 31 (which is the resent version)

16, as the short form of of JRE 1.6., is not a real naming but a relict to older versions, as Sun/Oracle changed the numbering. have a look at any page with java-resouces and you will find out. 

m.
Comment 10 mhonline 2012-03-06 15:26:36 UTC
I guess, there are more than one problems in this.
(UNO-Problems: some buttons/Help is not working)

however, here is one (to reproduce):
You need a german language (or maybe any non-english)-language-version

- open options
- open "paths"
- try to change path

impossible, due to the problem, that hidden-directories are not visible
(eng:"application data": visible - german: "Anwendungsdaten": invisible)

so, the path-setting is pointing to nowhere, which seems to crash LO when LO is trying a make a document-backup, and so on. Note: in VISTA etc, there is a symbolic link to the "application data", which exists also on non-english system. Win2K does not have this. 

Have fun

m.
Comment 11 Petr Mladek 2012-03-08 07:24:32 UTC
Is anyone else able to try L0-3.5 on Windows2000? I wonder if it is a common problem or if it is specific for the reporter system.

The comment 10 is really interesting. I would like to hear a comment from Windows expert on it.

I guess that files in hidden directories are still accessible if you know the path. They just do not appear in the file manager by default. Or I am wrong?

Also I wonder why the symlink is missing. Is it because Win2k does not support symlinks?
Comment 12 Petr Mladek 2012-03-08 07:26:32 UTC
This bug affects only Win2k users or this particular users. It should not block 3.5.1 release that brings many fixes for other users => lowering the severity a bit.
Comment 13 Rainer Bielefeld Retired 2012-03-08 07:27:45 UTC
Cesare, can you check and leave a comment?
Comment 14 Don't use this account, use tml@iki.fi 2012-03-08 13:35:43 UTC
I think it would be simplest to just do what the bug reporter said and "remove the
WIN2000 immidiatly from compatibility-list"... (Regarless whether this confusing report makes much sense or not.)
Comment 15 Cesare Leonardi 2012-03-08 13:51:38 UTC
(In reply to comment #13)
> Cesare, can you check and leave a comment?

Thank you Rainer for pointing my attention to this bug.

At work i have several Win2000 Pro SP4 PCs running different version of LibreOffice and different JRE6 versions. At the moment only one is using LO 3.5.0 and i cannot reproduce the Save as crash reported by Martin nor the change path option (see attachments): it's working ok for me.

More detail:
LibreOffice: 3.5.0rc3 (should be equal to 3.5.0), Italian localization
JRE installed: 1.6.0_27 and 1.3.1
.Net installed: 1.1 and 2.0 SP1

In the next days i'm going to test LO 3.5.1rc2.
If you need more details, let me know.

Martin, could it be that the last path you used to save files are now vanished or not accessible? That could give an explaination to either crashes.
And for the crash resolved after removing JRE, might be worth to test with an older JRE version.

Finally i assume you have an updated Win2000 SP4, right? Are you able to try on another Win2000 PC? And if you cannot, you can retry inside a fresh new account?

Cesare.
Comment 16 Cesare Leonardi 2012-03-08 13:52:51 UTC
Created attachment 58210 [details]
Save as is working for me
Comment 17 Cesare Leonardi 2012-03-08 13:54:13 UTC
Created attachment 58211 [details]
I can change the paths in the option window
Comment 18 Cesare Leonardi 2012-03-08 14:20:55 UTC
(In reply to comment #14)
> I think it would be simplest to just do what the bug reporter said and "remove
> the
> WIN2000 immidiatly from compatibility-list"... (Regarless whether this
> confusing report makes much sense or not.)

This will be surely unpleasant for me but it had to happen sooner or later.

I suppose the biggest problem for you developers is that nobody is able to test the Win2000 platform anymore. And the number of users is probably very low today.

I only ask you to consider waiting until real nasty and difficult to resolve bugs will arise. Something for which that compatibility will be considered a stopper for the project advancement.

Until i'll have Win2000 PCs, you can consider me available to make install and usage tests. I'm happy to help if i can.

Cesare.
Comment 19 mhonline 2012-03-08 20:21:45 UTC
well, confusing, okay.

as said, the problem is not always reproducable with new files, but always with that file I attached here. (private, for your guidance only, not to come into the wild) (And, against the OP, with that file I also crashed LO on XP)

Not sure, but it seems, that LO will terminate with crash only, when there is only one file left open, and if last action is "close file"/discard changes.

actually to me these issues look like:
- odf-version-handling is not functioning
- setting, errorhandling and filehandling with not existing paths does not work

m.
Comment 20 mhonline 2012-03-08 20:24:41 UTC
Created attachment 58215 [details]
file causes crash
Comment 21 Don't use this account, use tml@iki.fi 2012-03-08 22:30:11 UTC
Note that removing Win2000 from the "compatibility-list", whatever that is (URL?), wouldn't mean that we would intentionally make it not work on Windows 2000. We could just ignore bug reports about LO on Windows 2000.
Comment 22 Don't use this account, use tml@iki.fi 2012-03-08 22:31:36 UTC
> with that file I also crashed LO on XP

So it is not related to this bug report then at all? Or is this bug report now suddenly about some crash that happens on all Windows versions? Sheesh.
Comment 23 Petr Mladek 2012-03-09 08:59:09 UTC
Just for record, Volker Merschmann <merschmann at gmail dot com> wrote me the following:

--- cut ---
I remember the last OOo-Version wasn't even installable under all circumstances.
See https://issues.apache.org/ooo/show_bug.cgi?id=116035

We had lengthy discussions on dropping W2K from the list of supported
systems then.

The last LO that I could test was 3.3RC2 and it did not even start.
(Talked to thb about that, long ago...)
--- cut ---

Well, I think that we added MSVCR90.DLL into LO, so we are not affected by  i#116035.
Comment 24 Urmas 2012-03-09 10:12:03 UTC
Document causes sporadic crashes on XP too (upon exiting).
The visibility of Application Data directory depends on corresponding Explorer setting.
'Schablone existiert bereits' is a known problem with user profiles.
Other then that I found no issues with LO on W2K SP4.
Comment 25 Cesare Leonardi 2012-03-09 12:11:50 UTC
(In reply to comment #20)
> Created attachment 58215 [details]
> file causes crash

With this specific file, crash on exit for me too (Win2k SP4).
Comment 26 Cesare Leonardi 2012-03-09 12:27:18 UTC
(In reply to comment #21)
> Note that removing Win2000 from the "compatibility-list", whatever that is
> (URL?), wouldn't mean that we would intentionally make it not work on Windows
> 2000. We could just ignore bug reports about LO on Windows 2000.

If you ignore bugs, last Win2k users will not have any motivation in filing them anymore and sooner or later that platform will be broken.

System requirements URL:
http://www.libreoffice.org/get-help/system-requirements/
Comment 27 Pedro 2012-03-13 05:33:01 UTC
No problem at all working or changing Temp folder in LibreOffice 3.5.0 under Windows 2000 PT-PT. I think this bug could be closed as WORKSFORME since it seems to be a problem on the user system.

HOWEVER the file included for testing does consistently crash LibreOffice (regardless of version) when closing LO after SaveAs or creates a lock file even when it is closed correctly...
Comment 28 Petr Mladek 2012-03-14 02:45:25 UTC
OK, Cesare and Pedro are able to use LO on win2k without problem. I do not see any reason to remove it from the supported platform at this stage. => let's close this bug for now.

Please open separate bug for the crashing document.
Comment 29 mhonline 2012-03-17 21:07:23 UTC
hm, funny
in 3.5.1 it is not crashing anymore, but not all is working,

-- system-folders with attribute hidden still unvisible
-- some odt opend from file-menu will be treated as ott, but works when opend from explorer
-- the template-errors (wrong default template,optins/setup broken) 
-- the list of recent documents is always empty
 
However, the problem of lost lock-files and the update from old odf-versions seems to be solved.

Frankly, part of the problems where solved, a part not.

m.
Comment 30 tomasz86 2012-08-08 04:08:32 UTC
I run a Windows 2000 support site:
http://www.windows2000.tk/
and other information:
http://www.msfn.org/board/forum/130-hotstream/
http://www.ryanvm.net/forum/viewtopic.php?t=9254

I've tested LibreOffice 3.5.5.3 on both my desktop system (all official & unofficial updates installed) and on a VM (only official updates) and can't reproduce the bugs mentioned in this thread. Even if you don't want to use any unofficial updates you should always make sure that your system is fully up-to-date, i.e. that you've got installed all official system updates, IE6 with all updates, Script 5.7 with all updates, Windows Installer 3.1 with all updates, MS VC++ 2005/2008 with all updates, etc.

From my observations LibreOffice works perfectly fine in Windows 2000 under the conditions mentioned above. I'd also like to say thank you to all the LibreOffice developers for keeping the compatibility with the best OS produced by Microsoft.
Comment 31 Rainer Bielefeld Retired 2012-08-08 04:23:02 UTC
<http://wiki.documentfoundation.org/BugReport_Details#Version>
Comment 32 Urmas 2013-01-31 14:07:27 UTC
As Libreoffice 4 cannot be installed without .NET 4 runtime, I believe it is actual again.
Comment 33 Don't use this account, use tml@iki.fi 2013-01-31 14:15:15 UTC
LibreOffice 4 can now be installed without .NET 4 (on XP, Vista, Windows 7), as far as I know. Whether it can be installed on Windows 2000 or not, or whether it works if installed on Windows 2000,  is not related to that, but to other things. Like that it uses APIs that are not present on Windows 2000. Anyway, we don't support Windows 2000 any more.
Comment 34 Not Assigned 2013-01-31 14:32:51 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=19edf0dca7d759f15929f6b701f3e6b6d1e8b955

fdo#46706 Windows 2000 is not supported any more



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 35 Not Assigned 2013-01-31 20:47:40 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b865d4fceb035d9de481f73724c2473f2a893b6e&h=libreoffice-4-0

fdo#46706 Windows 2000 is not supported any more


It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.