Bug Hunting Session
Bug 46731 - : Open... file list is empty
Summary: : Open... file list is empty
Status: RESOLVED DUPLICATE of bug 46074
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-28 09:08 UTC by iaa_1
Modified: 2012-03-10 00:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description iaa_1 2012-02-28 09:08:03 UTC
Problem description: 
The list of files, that were already previous opened, at least one time, is empty.

Steps to reproduce:
1. Start Libreoffice 3.5.0 over an desktop icon
2. click next to the 'Open' button (dropdown arrow)
3. It is NOT showing any previous opened documents or documents that are opened later

Current behavior:
There is no file to open by selection.

Expected behavior:
There should be a list of documents that I opened already with LibO 3.4. Or at least it should add the file to the list if I'm opening it at least one time with LibreOffice 3.5.

Platform (if different from the browser): 
Windows 7, 64 Bit
Comment 1 treuschle 2012-03-01 00:21:23 UTC
During the migration procedure from LibO 3.4.5 to LibO 3.5.0, the profile file 'registrymodifications.xcu' in AppData\Roaming\Libreoffice\3\user is modified. In particular I have noticed that in the description of the previously opened documents some features like '<value>writer8</value' are replaced by '<value xsi:nil="true"/>'. The list of documents should not be empty but the migration process seems to prevent the display of the documents already opened in LibO 3.4.5 and, more annoying, adding any new document in this list.
If you remove in registrymodifications.xcu all the lines dealing with the history of opened documents, the list will start empty but new files will be added to the list once opened and closed.

Platform : Windows 7, 64 bits
Comment 2 Rainer Bielefeld Retired 2012-03-10 00:51:40 UTC
Known Problem "Bug 46074 - FILEOPEN: No Recent Documents..."

@reporter:
Please feel free to reopen this Bug if you find evidence that we have an independent issue here.

*** This bug has been marked as a duplicate of bug 46074 ***