Bug 46737 - : Custom keyboard shortcuts: Mac equivalent to alt-key shortcuts not working.
Summary: : Custom keyboard shortcuts: Mac equivalent to alt-key shortcuts not working.
Status: RESOLVED DUPLICATE of bug 43680
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-28 13:17 UTC by Mark Simon
Modified: 2012-06-17 13:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Simon 2012-02-28 13:17:02 UTC
I have assigned a number of shortcuts using the alt-key in the Windows version, mainly for custom styles.

I have gone through a similar process in the Macintosh version; here it appears to use the control-key for the additional shortcuts.

The problem is that all of these shortcuts are ignored in favour of the system-defined control key shortcuts. The best I can do is to have them ignored completely, which will only enter the unmodified key.

For example,

1. Tools | Customize | Keyboard | Choose a style or other action
2. Assign to ^C (or something)
3. Try Ctrl-C; with or without any combination of modifiers

If the Ctrl-Key already has a meaning (such as Ctrl-H for backspace), that will be applied; otherwise the unmodified key is entered.

I am using LO 3.50 on OSX Lion 10.7.3
Comment 1 Joel Madero 2012-06-17 13:53:26 UTC
This is a duplicate and does not qualify for a MAJOR bug, please post any addition information to the other bug (#43860). Thanks for posting

*** This bug has been marked as a duplicate of bug 43860 ***
Comment 2 Joel Madero 2012-06-17 13:54:28 UTC

*** This bug has been marked as a duplicate of bug 43680 ***